From: Felix Fietkau <nbd@openwrt.org>
Date: Sun, 20 Jul 2014 08:18:50 +0000 (+0000)
Subject: x86: remove the arbitrary limitation of vmware/virtualbox images to ext4, select... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=c718d0b10cea2d539b3f7db0beccf298caf0659e;p=openwrt%2Fstaging%2Fneocturne.git

x86: remove the arbitrary limitation of vmware/virtualbox images to ext4, select TARGET_IMAGES_PAD instead

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 41763
---

diff --git a/config/Config-images.in b/config/Config-images.in
index 9aeebc11f8..2231b600a9 100644
--- a/config/Config-images.in
+++ b/config/Config-images.in
@@ -229,14 +229,13 @@ menu "Target Images"
 		bool "Build VirtualBox image files (VDI)"
 		depends on TARGET_x86 || TARGET_x86_64
 		select GRUB_IMAGES
-		select TARGET_ROOTFS_EXT4FS
+		select TARGET_IMAGES_PAD
 		select PACKAGE_kmod-e1000
 
 	config VMDK_IMAGES
 		bool "Build VMware image files (VMDK)"
 		depends on TARGET_x86 || TARGET_x86_64
-		select GRUB_IMAGES
-		select TARGET_ROOTFS_EXT4FS
+		select TARGET_IMAGES_PAD
 		select PACKAGE_kmod-e1000
 
 	config TARGET_IMAGES_PAD
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 03aa350da2..59837180f1 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -160,27 +160,21 @@ endef
 
 ifneq ($(CONFIG_VDI_IMAGES),)
   define Image/Build/vdi
-    # left here because the image builder doesnt need these
-    ifeq ($(1),ext4)
-		rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
-		qemu-img convert -f raw -O vdi \
-			$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
-			$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
-		# XXX: VBoxManage insists on setting perms to 0600
-		chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
-    endif
+	rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
+	qemu-img convert -f raw -O vdi \
+		$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
+		$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
+	# XXX: VBoxManage insists on setting perms to 0600
+	chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
   endef
 endif
 
 ifneq ($(CONFIG_VMDK_IMAGES),)
   define Image/Build/vmdk
-    # left here because the image builder doesnt need these
-    ifeq ($(1),ext4)
-		rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk || true
-		qemu-img convert -f raw -O vmdk \
-			$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
-			$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk
-    endif
+	rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk || true
+	qemu-img convert -f raw -O vmdk \
+		$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
+		$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk
   endef
 endif