From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 20 Feb 2012 10:51:48 +0000 (+0000)
Subject: ar71xx: switch to kmod-gpio-button-hotplug
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=c9188104140685f3d13c789f2823dbad5b3ac0f1;p=openwrt%2Fstaging%2Fneocturne.git

ar71xx: switch to kmod-gpio-button-hotplug

SVN-Revision: 30660
---

diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 96201eeb0a..8e9931de0c 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -18,8 +18,7 @@ LINUX_VERSION:=3.2.5
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-	kmod-leds-gpio kmod-input-core kmod-input-polldev \
-	kmod-input-gpio-keys-polled kmod-button-hotplug swconfig \
+	kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
 	kmod-ath9k wpad-mini uboot-envtools
 
 define Target/Description
diff --git a/target/linux/ar71xx/base-files/lib/preinit/05_enable_reset_button_ar71xx b/target/linux/ar71xx/base-files/lib/preinit/05_enable_reset_button_ar71xx
index 305fe0018b..317c8d15a6 100644
--- a/target/linux/ar71xx/base-files/lib/preinit/05_enable_reset_button_ar71xx
+++ b/target/linux/ar71xx/base-files/lib/preinit/05_enable_reset_button_ar71xx
@@ -6,10 +6,7 @@
 
 
 preinit_enable_reset_button() {
-	insmod input-core
-	insmod input-polldev
-	insmod gpio_keys_polled
-	insmod button-hotplug
+	insmod gpio-button-hotplug
 }
 
 boot_hook_add preinit_main preinit_enable_reset_button