From: Christian Lamparter <chunkeey@gmail.com>
Date: Fri, 31 Jul 2020 16:17:34 +0000 (+0200)
Subject: apm821xx: disable WNDR4700 5.4 image
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=caa6ada969ddf63eb753840fe9fa2acc726e5d57;p=openwrt%2Fstaging%2Fzorun.git

apm821xx: disable WNDR4700 5.4 image

The compressed image that the buildbots are building is too large for
the netgear uboot and it crashes and soft-bricks the device.

| Uncompressing Kernel Image ...
| LZMA: uncompress or overwrite error 1 - must RESET board to recover

The whole target likely needs to be switched zImage which is a major
hassle due to powerpc's legacy bootwrapper setup as compared to ARM.
So for now, disable the device.

Reported-by: Wiktor Stasiak (FS#3258)
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
---

diff --git a/target/linux/apm821xx/image/nand.mk b/target/linux/apm821xx/image/nand.mk
index 29a4be0189..845770b89f 100644
--- a/target/linux/apm821xx/image/nand.mk
+++ b/target/linux/apm821xx/image/nand.mk
@@ -117,5 +117,6 @@ define Device/netgear_wndr4700
   NETGEAR_HW_ID := 29763875+128+256
   UBINIZE_OPTS := -E 5
   SUPPORTED_DEVICES += wndr4700
+  DEFAULT := n
 endef
 TARGET_DEVICES += netgear_wndr4700