From: Felix Fietkau <nbd@openwrt.org>
Date: Wed, 8 Oct 2008 12:07:14 +0000 (+0000)
Subject: fix inotify detection for linux 2.4 (fixes glib2 and packages that depend on it on... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=cb73e4ad91a312aad257784f804d8b2a0430b8a8;p=openwrt%2Fstaging%2Fneocturne.git

fix inotify detection for linux 2.4 (fixes glib2 and packages that depend on it on brcm-2.4)

SVN-Revision: 12896
---

diff --git a/include/package.mk b/include/package.mk
index d67a386225..0f3d21ee9e 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -31,7 +31,11 @@ include $(INCLUDE_DIR)/package-bin.mk
 include $(INCLUDE_DIR)/autotools.mk
 
 override MAKEFLAGS=
-export CONFIG_SITE:=$(INCLUDE_DIR)/site/$(patsubst %gnueabi,%,$(REAL_GNU_TARGET_NAME))
+CONFIG_SITE:=$(INCLUDE_DIR)/site/$(patsubst %gnueabi,%,$(REAL_GNU_TARGET_NAME))
+ifneq ($(CONFIG_LINUX_2_4),)
+  CONFIG_SITE:=$(subst linux-,linux2.4-,$(CONFIG_SITE))
+endif
+export CONFIG_SITE
 CUR_MAKEFILE:=$(filter-out Makefile,$(firstword $(MAKEFILE_LIST)))
 SUBMAKE:=$(NO_TRACE_MAKE) $(if $(CUR_MAKEFILE),-f $(CUR_MAKEFILE))
 
diff --git a/include/site/mipsel-linux2.4-uclibc b/include/site/mipsel-linux2.4-uclibc
new file mode 100644
index 0000000000..3412411cb4
--- /dev/null
+++ b/include/site/mipsel-linux2.4-uclibc
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+. $TOPDIR/include/site/mipsel-linux
+. $TOPDIR/include/site/linux-uclibc
+ac_cv_header_sys_inotify_h=no