From: Felix Fietkau <nbd@openwrt.org>
Date: Thu, 14 Feb 2008 22:01:15 +0000 (+0000)
Subject: add eabi autoselection for the kernel as well - fixes iptables problems
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=cce8347d18f6d3decc3192fcce39fa5a6db0e5e8;p=openwrt%2Fstaging%2Fwigyori.git

add eabi autoselection for the kernel as well - fixes iptables problems

SVN-Revision: 10461
---

diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
index ec931a0a99..eec8d13f72 100644
--- a/target/linux/ixp4xx/Makefile
+++ b/target/linux/ixp4xx/Makefile
@@ -16,6 +16,12 @@ LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 
+define Kernel/Configure
+	$(call Kernel/Configure/Default)
+	$(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+	$(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
+
 DEFAULT_PACKAGES += ixp4xx-microcode
 
 $(eval $(call BuildTarget))
diff --git a/target/linux/ixp4xx/config-default b/target/linux/ixp4xx/config-default
index 5116bd82b6..5b76e9c54d 100644
--- a/target/linux/ixp4xx/config-default
+++ b/target/linux/ixp4xx/config-default
@@ -1,5 +1,5 @@
 # CONFIG_8139TOO is not set
-CONFIG_AEABI=y
+# CONFIG_AEABI is not set
 CONFIG_ALIGNMENT_TRAP=y
 # CONFIG_APM is not set
 # CONFIG_ARCH_AAEC2000 is not set
@@ -298,7 +298,7 @@ CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED=y
 # CONFIG_NO_IDLE_HZ is not set
 # CONFIG_NTFS_FS is not set
 # CONFIG_NVRAM is not set
-CONFIG_OABI_COMPAT=y
+# CONFIG_OABI_COMPAT is not set
 # CONFIG_PATA_ALI is not set
 # CONFIG_PATA_AMD is not set
 CONFIG_PATA_ARTOP=m