From: David Bauer <mail@david-bauer.net>
Date: Tue, 7 Jul 2020 08:32:09 +0000 (+0200)
Subject: build: conditionally enable testing-kernel feature
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=cf6f01c0e69a31afc6c5f384405ace51e03fe481;p=openwrt%2Fstaging%2Fldir.git

build: conditionally enable testing-kernel feature

Only enable the testing-kernel feature for the target when the testing
kernel version does not match the stable kernel version.

This way, the option for building the testing kernel in the build config
menu is only exposed when there's a testing kernel available.

Signed-off-by: David Bauer <mail@david-bauer.net>
Acked-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---

diff --git a/include/target.mk b/include/target.mk
index a2ceb7f783..64292138b7 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -223,7 +223,9 @@ ifeq ($(DUMP),1)
     .PRECIOUS: $(TMP_CONFIG)
 
     ifdef KERNEL_TESTING_PATCHVER
-      FEATURES += testing-kernel
+      ifneq ($(KERNEL_TESTING_PATCHVER),$(KERNEL_PATCHVER))
+        FEATURES += testing-kernel
+      endif
     endif
     ifneq ($(CONFIG_OF),)
       FEATURES += dt