From: Birger Koblitz <git@birger-koblitz.de>
Date: Tue, 28 Dec 2021 18:56:59 +0000 (+0100)
Subject: realtek: Set RTL838X sub-target specific properties
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=cf8e1459558d60322945bca53f50b29ba13e6dc0;p=openwrt%2Fstaging%2Fnbd.git

realtek: Set RTL838X sub-target specific properties

This defines the sub-target specific properties for the RTL838X
sub-target.

Signed-off-by: Birger Koblitz <git@birger-koblitz.de>
---

diff --git a/target/linux/realtek/rtl838x/target.mk b/target/linux/realtek/rtl838x/target.mk
index f5cb1fb19b..ee658ea986 100644
--- a/target/linux/realtek/rtl838x/target.mk
+++ b/target/linux/realtek/rtl838x/target.mk
@@ -1 +1,15 @@
-BOARDNAME:=Generic
+# SPDX-License-Identifier: GPL-2.0-only
+ARCH:=mips
+SUBTARGET:=rtl838x
+CPU_TYPE:=4kec
+BOARD:=realtek
+BOARDNAME:=Realtek MIPS RTL838X
+
+KERNEL_PATCHVER:=5.10
+
+define Target/Description
+	Build firmware images for Realtek RTL838x based boards.
+endef
+
+FEATURES := $(filter-out mips16,$(FEATURES))
+