From: Jo-Philipp Wich <jow@openwrt.org>
Date: Tue, 20 Oct 2009 17:07:08 +0000 (+0000)
Subject: base-files: only try to execute watchdog if binary is present
X-Git-Tag: reboot~22129
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=cfe1bc11adee94c4ce07d50fb960429fa17350aa;p=openwrt%2Fstaging%2Fxback.git

base-files: only try to execute watchdog if binary is present

SVN-Revision: 18102
---

diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 0fdbf11391..68cebfed73 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=32
+PKG_RELEASE:=33
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
diff --git a/package/base-files/files/etc/init.d/watchdog b/package/base-files/files/etc/init.d/watchdog
index adb8f57c13..861a1f9eb0 100755
--- a/package/base-files/files/etc/init.d/watchdog
+++ b/package/base-files/files/etc/init.d/watchdog
@@ -3,5 +3,6 @@
 
 START=97
 start() {
-        [ -c /dev/watchdog ] && watchdog -t 5 /dev/watchdog
+        [ -c /dev/watchdog ] && [ -x /sbin/watchdog ] && \
+        	watchdog -t 5 /dev/watchdog
 }