From: Jo-Philipp Wich <jo@mein.io>
Date: Sat, 15 Oct 2016 23:59:43 +0000 (+0200)
Subject: config: ext4: drop option to set maximum number of inodes
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=d1ae4c4958e6394a0f00be334bc045bce9f0614d;p=openwrt%2Fstaging%2Fblogic.git

config: ext4: drop option to set maximum number of inodes

There is very little practical use to limit the number of available inodes on
an ext4 filesystem and the make_ext4fs utility is able to calculate useful
defaults by itself.

Drop the option to make resulting ext4 filesystems more flexible by default.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Acked-by: Michael Heimpold <mhei@heimpold.de>
---

diff --git a/config/Config-images.in b/config/Config-images.in
index 05b817bad4c9..1a6951dfb781 100644
--- a/config/Config-images.in
+++ b/config/Config-images.in
@@ -73,13 +73,6 @@ menu "Target Images"
 		help
 		  Build an ext4 root filesystem.
 
-		config TARGET_EXT4_MAXINODE
-			int "Maximum number of inodes in root filesystem"
-			depends on TARGET_ROOTFS_EXT4FS
-			default 6000
-			help
-			  Select the maximum number of inodes in the root filesystem.
-
 		config TARGET_EXT4_RESERVED_PCT
 			int "Percentage of reserved blocks in root filesystem"
 			depends on TARGET_ROOTFS_EXT4FS
diff --git a/include/image.mk b/include/image.mk
index 59dd66fa9c2b..8b183ab58a83 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -244,7 +244,6 @@ E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_PARTSIZE)*1024*1024)))
 define Image/mkfs/ext4
 	$(STAGING_DIR_HOST)/bin/make_ext4fs \
 		-l $(E2SIZE) -b $(CONFIG_TARGET_EXT4_BLOCKSIZE) \
-		-i $(CONFIG_TARGET_EXT4_MAXINODE) \
 		$(if $(CONFIG_TARGET_EXT4_RESERVED_PCT),-m $(CONFIG_TARGET_EXT4_RESERVED_PCT)) \
 		$(if $(CONFIG_TARGET_EXT4_JOURNAL),,-J) \
 		$(if $(SOURCE_DATE_EPOCH),-T $(SOURCE_DATE_EPOCH)) \