From: Chris Blake <chrisrblake93@gmail.com>
Date: Fri, 31 Mar 2017 09:31:21 +0000 (-0500)
Subject: apm821xx: Add default packages to NAND target
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=d1c3a9485a90fff9bf7083faba4138e14dcdae7d;p=openwrt%2Fstaging%2Fldir.git

apm821xx: Add default packages to NAND target

This moves core router packages to the NAND target, to ensure they are
applied to all images. This change is being done due to an issue found
when flashing the MX60W image, which came without these when built as a
multi image.

Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
---

diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 355333695d..1dae2b6636 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -69,7 +69,7 @@ endef
 
 define Device/mr24
   DEVICE_TITLE := Cisco Meraki MR24
-  DEVICE_PACKAGES := kmod-spi-gpio kmod-ath9k wpad-mini
+  DEVICE_PACKAGES := kmod-spi-gpio
   DEVICE_PROFILE := MR24
   DEVICE_DTS := MR24
   BLOCKSIZE := 63k
@@ -89,8 +89,8 @@ TARGET_DEVICES += mr24
 
 define Device/mx60
   DEVICE_TITLE := Cisco Meraki MX60
-  DEVICE_PACKAGES := kmod-spi-gpio swconfig kmod-usb-ledtrig-usbport \
-	kmod-usb-dwc2 kmod-usb-storage block-mount
+  DEVICE_PACKAGES := kmod-spi-gpio kmod-usb-ledtrig-usbport kmod-usb-dwc2 \
+  kmod-usb-storage block-mount
   DEVICE_PROFILE := MX60
   DEVICE_DTS := MX60
   BLOCKSIZE := 63k
@@ -115,7 +115,6 @@ TARGET_DEVICES += mx60
 define Device/mx60w
 $(Device/mx60)
   DEVICE_TITLE := Cisco Meraki MX60W
-  DEVICE_PACKAGES += kmod-ath9k wpad-mini
 endef
 TARGET_DEVICES += mx60w
 
@@ -160,10 +159,10 @@ endef
 define Device/WNDR4700
   DEVICE_TITLE := Netgear Centria N900 WNDR4700/WNDR4720
   DEVICE_PACKAGES := badblocks block-mount e2fsprogs \
-	kmod-ath9k kmod-dm kmod-fs-ext4 kmod-fs-vfat kmod-usb-ledtrig-usbport \
+	kmod-dm kmod-fs-ext4 kmod-fs-vfat kmod-usb-ledtrig-usbport \
 	kmod-md-mod kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-iso8859-15 \
 	kmod-nls-utf8 kmod-usb3 kmod-usb-dwc2 kmod-usb-storage \
-	partx-utils swconfig wpad-mini
+	partx-utils
   DEVICE_NAME := wndr4700
   DEVICE_PROFILE := wndr4700
   DEVICE_DTS := wndr4700
diff --git a/target/linux/apm821xx/nand/profiles/00-default.mk b/target/linux/apm821xx/nand/profiles/00-default.mk
index 12c38ec7ba..8c2203f5a9 100644
--- a/target/linux/apm821xx/nand/profiles/00-default.mk
+++ b/target/linux/apm821xx/nand/profiles/00-default.mk
@@ -9,10 +9,10 @@ define Profile/Default
   NAME:=Default Profile
   PRIORITY:=1
   PACKAGES := badblocks block-mount e2fsprogs \
-	kmod-ath9k kmod-dm kmod-fs-ext4 kmod-fs-vfat kmod-usb-ledtrig-usbport \
+	kmod-dm kmod-fs-ext4 kmod-fs-vfat kmod-usb-ledtrig-usbport \
 	kmod-md-mod kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-iso8859-15 \
 	kmod-nls-utf8 kmod-usb3 kmod-usb-dwc2 kmod-usb-storage \
-	kmod-spi-gpio partx-utils swconfig wpad-mini
+	kmod-spi-gpio partx-utils
 endef
 
 define Profile/Default/Description
diff --git a/target/linux/apm821xx/nand/target.mk b/target/linux/apm821xx/nand/target.mk
index a7d88b87c5..2dce530cef 100644
--- a/target/linux/apm821xx/nand/target.mk
+++ b/target/linux/apm821xx/nand/target.mk
@@ -1,6 +1,8 @@
 BOARDNAME:=Devices with NAND flash (Routers)
 FEATURES += nand pcie ramdisk squashfs usb
 
+DEFAULT_PACKAGES += kmod-ath9k swconfig wpad-mini
+
 define Target/Description
 	Build firmware images for APM821XX boards with NAND flash.
 	For routers like the MR24 or the WNDR4700.