From: Florian Fainelli <florian@openwrt.org>
Date: Tue, 26 May 2009 14:18:05 +0000 (+0000)
Subject: stop build when an error occurs and when BUILDLOG is set (#5160)
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=d334c1e9568c9f50a5851d868a40fe8a736d4ddc;p=openwrt%2Fstaging%2Flinusw.git

stop build when an error occurs and when BUILDLOG is set (#5160)

SVN-Revision: 16079
---

diff --git a/include/subdir.mk b/include/subdir.mk
index 1e669443be..26a8626524 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -35,7 +35,7 @@ define subdir
       )
       $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
 	  	$(if $(BUILD_LOG),@mkdir -p $(TOPDIR)/logs/$(1)/$(bd))
-		+$$(SUBMAKE) -C $(1)/$(bd) $(target) $(if $(BUILD_LOG),SILENT= 2>&1 | tee $(TOPDIR)/logs/$(1)/$(bd)/$(target).txt) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE,   ERROR: $(1)/$(bd) failed to build.))
+		+$(if $(BUILD_LOG),set -o pipefail;) $$(SUBMAKE) -C $(1)/$(bd) $(target) $(if $(BUILD_LOG),SILENT= 2>&1 | tee $(TOPDIR)/logs/$(1)/$(bd)/$(target).txt) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE,   ERROR: $(1)/$(bd) failed to build.))
         $$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))
 
       # legacy targets