From: Jonas Gorski <jonas.gorski@gmail.com>
Date: Mon, 10 Sep 2018 09:42:53 +0000 (+0200)
Subject: opkg: drop argument from check_signature in opkg.conf
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=d3bf5ff9bc7b55b2a3dab93853b33a0cd2c4ca47;p=openwrt%2Fstaging%2Fnbd.git

opkg: drop argument from check_signature in opkg.conf

check_signature is a bool option and doesn't take any arguments. The
presence of the 1 falsely suggests setting it to 0 disables the check,
while the option actually needs to be removed or commented out to be
disabled. So remove the argument to make it more clear.

Fixes: beca028bd6bb ("build: add integration for managing opkg package feed keys")
Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
---

diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index f00e574de0..67105675e8 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=opkg
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_FLAGS:=essential
 
 PKG_SOURCE_PROTO:=git
@@ -89,7 +89,7 @@ define Package/opkg/install
 	$(INSTALL_BIN) ./files/20_migrate-feeds $(1)/etc/uci-defaults/
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
   ifneq ($(CONFIG_SIGNED_PACKAGES),)
-	echo "option check_signature 1" >> $(1)/etc/opkg.conf
+	echo "option check_signature" >> $(1)/etc/opkg.conf
   endif
 	$(INSTALL_DIR) $(1)/usr/sbin
 	$(INSTALL_BIN) ./files/opkg-key $(1)/usr/sbin/