From: Felix Fietkau <nbd@openwrt.org>
Date: Fri, 30 Oct 2015 22:01:27 +0000 (+0000)
Subject: build: make mkfs-* depend on kernel installation to fix parallel build issues
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=d495ef6d59f9581bb5909abe7d39f3fd6d7919f0;p=openwrt%2Fstaging%2Fnbd.git

build: make mkfs-* depend on kernel installation to fix parallel build issues

Reported-by: Petr Štetiar <ynezz@true.cz>
Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 47296
---

diff --git a/include/image.mk b/include/image.mk
index c59222e415..4e22fa59a0 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -282,7 +282,7 @@ endef
 define BuildImage/mkfs
   install: mkfs-$(1)
   .PHONY: mkfs-$(1)
-  mkfs-$(1): mkfs_prepare
+  mkfs-$(1): kernel_prepare
 	$(Image/mkfs/$(1))
 	$(call Build/mkfs/default,$(1))
 	$(call Build/mkfs/$(1),$(1))