From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 26 Mar 2012 10:07:50 +0000 (+0000)
Subject: tools: fix stat symlink if destination already exists
X-Git-Tag: reboot~14436
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=d5234a74b610795ac899a8f4fc2648d2ee1745e5;p=openwrt%2Fopenwrt.git

tools: fix stat symlink if destination already exists

SVN-Revision: 31072
---

diff --git a/tools/Makefile b/tools/Makefile
index 48cfbbcc5f..87a2940d02 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -102,6 +102,7 @@ endef
 endif
 
 $(STAGING_DIR_HOST)/bin/stat: $(STAGING_DIR)/.prepared
+	@rm -f $@
 	@if stat --version > /dev/null 2>&1; then \
 		ln -s `which stat` $@; \
 	elif gstat --version > /dev/null 2>&1; then \