From: Florian Fainelli <florian@openwrt.org>
Date: Fri, 13 Jul 2007 13:10:15 +0000 (+0000)
Subject: Move pciutils to trunk (#2061)
X-Git-Tag: reboot~28677
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=d700970b00e10c9d23504130168e505595cc7cc8;p=openwrt%2Fstaging%2Fpepe2k.git

Move pciutils to trunk (#2061)

SVN-Revision: 7966
---

diff --git a/package/pciutils/Makefile b/package/pciutils/Makefile
new file mode 100644
index 0000000000..ec404aa4a1
--- /dev/null
+++ b/package/pciutils/Makefile
@@ -0,0 +1,74 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pciutils
+PKG_VERSION:=2.2.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.kernel.org/pub/software/utils/pciutils/ \
+	ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
+PKG_MD5SUM:=c18e2a5f04e9abae5a42439de294f086
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/pciutils
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Linux PCI Utilities
+  DESCRIPTION:=\
+	This package contains various utilities for inspecting and setting of \\\
+	devices connected to the PCI bus.
+  URL:=http://www.kernel.org/pub/software/utils/pciutils/
+endef
+
+define Package/pciutils/postinst
+#!/bin/sh
+$${IPKG_INSTROOT}/usr/sbin/update-pciids.sh
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+	$(call Build/Compile/Default, \
+		CFLAGS="$(TARGET_CFLAGS)" \
+		IDSDIR="/usr/share" \
+		HOST="$(GNU_TARGET_NAME)" \
+	)
+endef
+
+define Build/InstallDev
+	$(INSTALL_DIR) $(STAGING_DIR)/usr/lib
+	$(CP) $(PKG_BUILD_DIR)/lib/libpci.a $(STAGING_DIR)/usr/lib
+	$(INSTALL_DIR) $(STAGING_DIR)/usr/include/pci
+	$(CP) $(PKG_BUILD_DIR)/lib/pci.h $(STAGING_DIR)/usr/include/pci
+	$(CP) $(PKG_BUILD_DIR)/lib/config.h $(STAGING_DIR)/usr/include/pci
+	$(CP) $(PKG_BUILD_DIR)/lib/header.h $(STAGING_DIR)/usr/include/pci
+	$(CP) $(PKG_BUILD_DIR)/lib/types.h $(STAGING_DIR)/usr/include/pci
+endef
+
+define Build/UninstallDev
+	rm -rf \
+		$(STAGING_DIR)/usr/include/pci \
+		$(STAGING_DIR)/usr/lib/libpci.a
+endef
+
+define Package/pciutils/install
+	$(INSTALL_DIR) $(1)/usr/sbin
+	$(CP) $(PKG_BUILD_DIR)/{lspci,setpci,update-pciids.sh} $(1)/usr/sbin/
+	$(INSTALL_DIR) $(1)/usr/share
+	$(CP) $(PKG_BUILD_DIR)/pci.ids $(1)/usr/share/
+endef
+
+$(eval $(call BuildPackage,pciutils))