From: Gabor Juhos <juhosg@openwrt.org>
Date: Thu, 4 Oct 2012 06:34:09 +0000 (+0000)
Subject: ramips: add image for ALL0256N-8M
X-Git-Tag: reboot~12744
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=d832cd11f87942eb698e6cf702d8764677afaf81;p=openwrt%2Fstaging%2Fxback.git

ramips: add image for ALL0256N-8M

The new version of the ALL0256N now got 8MB SPI NOR flash instead of 4MB.
In order to expose the whole amount of flash, add another image which contains
the corresponding GENERIC_8M mtdparts.

[juhosg: change suffix from '8m' to '8M']

Patch by: Daniel Golle <dgolle@allnet.de>

SVN-Revision: 33614
---

diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index d1204f3e29..f8c7806875 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -389,6 +389,7 @@ endef
 
 define Image/Build/Profile/ALL0256N
 	$(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,all0256n,ALL0256N,ttyS1,57600,spi)
+	$(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,all0256n-8M,ALL0256N,ttyS1,57600,spi)
 endef
 
 define Image/Build/Profile/ALL5002