From: Yousong Zhou <yszhou4tech@gmail.com>
Date: Sun, 5 Mar 2017 08:17:17 +0000 (+0800)
Subject: build: cleanup tmp/ dir of target rootfs
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=dac629f71093715ea002c7949a9888188e58984e;p=openwrt%2Fstaging%2Fldir.git

build: cleanup tmp/ dir of target rootfs

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
---

diff --git a/include/rootfs.mk b/include/rootfs.mk
index c014b1d14a..74785cbbd3 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -80,6 +80,7 @@ define prepare_rootfs
 	@-find $(1) -name .svn  | $(XARGS) rm -rf
 	@-find $(1) -name .git  | $(XARGS) rm -rf
 	@-find $(1) -name '.#*' | $(XARGS) rm -f
+	rm -rf $(1)/tmp/*
 	rm -f $(1)/usr/lib/opkg/lists/*
 	rm -f $(1)/usr/lib/opkg/info/*.postinst*
 	rm -f $(1)/usr/lib/opkg/info/*.prerm*
diff --git a/package/Makefile b/package/Makefile
index ac8faecef2..4fdf415046 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -63,7 +63,7 @@ endif
 $(curdir)/install: $(TMP_DIR)/.build $(curdir)/merge $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),$(curdir)/merge-index)
 	- find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
 	rm -rf $(TARGET_DIR) $(TARGET_DIR_ORIG)
-	[ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp
+	mkdir -p $(TARGET_DIR)/tmp
 	$(call opkg,$(TARGET_DIR)) install \
 		$(call opkg_package_files,$(shell cat $(PACKAGE_INSTALL_FILES) 2>/dev/null))
 	@for file in $(PACKAGE_INSTALL_FILES); do \