From: John Crispin <john@phrozen.org>
Date: Thu, 10 May 2018 08:22:19 +0000 (+0200)
Subject: kernel: fix kmod-switch-rtl8366-smi dependency
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=dc629d9cf5afc03f67a294078ca1001e831c66c9;p=openwrt%2Fstaging%2Fldir.git

kernel: fix kmod-switch-rtl8366-smi dependency

Signed-off-by: John Crispin <john@phrozen.org>
---

diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 23939b62bf..f5e6d3d6f0 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -209,7 +209,7 @@ $(eval $(call KernelPackage,switch-ip17xx))
 define KernelPackage/switch-rtl8366-smi
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Realtek RTL8366 SMI switch interface support
-  DEPENDS:=@GPIO_SUPPORT +kmod-swconfig
+  DEPENDS:=@GPIO_SUPPORT +kmod-swconfig +CONFIG_OF:kmod-of-mdio
   KCONFIG:=CONFIG_RTL8366_SMI
   FILES:=$(LINUX_DIR)/drivers/net/phy/rtl8366_smi.ko
   AUTOLOAD:=$(call AutoLoad,42,rtl8366_smi)