From: Felix Fietkau <nbd@openwrt.org>
Date: Mon, 4 Jul 2005 20:18:35 +0000 (+0000)
Subject: change kernel package name to kernel-VERSION-BOARD to work around ipkg bug
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=dcef53bba25d27067d444c6e70af84ee718aadf4;p=openwrt%2Fstaging%2Fdedeckeh.git

change kernel package name to kernel-VERSION-BOARD to work around ipkg bug

SVN-Revision: 1340
---

diff --git a/openwrt/target/linux/control/kernel.control b/openwrt/target/linux/control/kernel.control
index 5432d21a0f..32e6fdc313 100644
--- a/openwrt/target/linux/control/kernel.control
+++ b/openwrt/target/linux/control/kernel.control
@@ -1,4 +1,3 @@
-Package: kernel
 Priority: optional
 Section: sys
 Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index e1ae0b3800..6f08cf67cc 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -40,7 +40,7 @@ IPKG_KERNEL:=IPKG_TMP=$(BUILD_DIR)/tmp IPKG_INSTROOT=$(LINUX_TARGET_DIR) IPKG_CO
 PKG_BUILD_DIR := $(LINUX_BUILD_DIR)/linux-modules
 PKG_RELEASE := 1
 
-KERNEL_IPKG:=$(LINUX_BUILD_DIR)/kernel_$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)_$(ARCH).ipk
+KERNEL_IPKG:=$(LINUX_BUILD_DIR)/kernel-$(LINUX_VERSION)-$(BOARD)_$(PKG_RELEASE)_$(ARCH).ipk
 KERNEL_IDIR:=$(LINUX_BUILD_DIR)/kernel-ipkg
 
 include $(LINUX_KCONFIG)
@@ -197,7 +197,8 @@ $(TARGET_MODULES_DIR):
 $(KERNEL_IPKG):
 	rm -rf $(KERNEL_IDIR)
 	mkdir -p $(KERNEL_IDIR)/etc
-	$(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE) $(ARCH)
+	$(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(PKG_RELEASE) $(ARCH)
+	echo 'Package: kernel-$(LINUX_VERSION)-$(BOARD)' >> $(KERNEL_IDIR)/CONTROL/control
 	if [ -f ./config/$(BOARD).modules ]; then \
 		cp ./config/$(BOARD).modules $(KERNEL_IDIR)/etc/modules; \
 	fi
diff --git a/openwrt/target/linux/rules.mk b/openwrt/target/linux/rules.mk
index 9446c343fa..75a96b4e65 100644
--- a/openwrt/target/linux/rules.mk
+++ b/openwrt/target/linux/rules.mk
@@ -6,9 +6,9 @@ KDEPEND_$(1):=$($(4))
 endif
 
 ifeq ($$(strip $(5)),)
-IDEPEND_$(1):=kernel ($(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE))
+IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE))
 else
-IDEPEND_$(1):=kernel ($(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)), $(5)
+IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE)), $(5)
 endif
 
 PKG_$(1) := $(PACKAGE_DIR)/kmod-$(2)_$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)_$(ARCH).ipk