From: Waldemar Brodkorb <mail@waldemar-brodkorb.de>
Date: Fri, 15 Jul 2005 15:15:02 +0000 (+0000)
Subject: add libamsel and amwall, an iptables frontend, like OpenBSD's pf, thx Eymen Alyaz
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=dd18fd3b85c4b8d9c1c7ff8a0b8c001f1a661cea;p=openwrt%2Fstaging%2Fdedeckeh.git

add libamsel and amwall, an iptables frontend, like OpenBSD's pf, thx Eymen Alyaz

SVN-Revision: 1438
---

diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index e3662b7762..4d31ead2e0 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -27,6 +27,7 @@ source "package/screen/Config.in"
 
 comment "Networking"
 source "package/aiccu/Config.in"
+source "package/amwall/Config.in"
 source "package/arptables/Config.in"
 source "package/arpwatch/Config.in"
 source "package/asterisk/Config.in"
@@ -99,6 +100,7 @@ source "package/wificonf/Config.in"
 
 comment "Libraries"
 source "package/glib/Config.in"
+source "package/libamsel/Config.in"
 source "package/libdb/Config.in"
 source "package/libelf/Config.in"
 source "package/libevent/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index f1687c4e78..8e37355ee8 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -4,6 +4,7 @@ include $(TOPDIR)/rules.mk
 package-:=tcp_wrappers
 package-y:=openwrt
 package-$(BR2_PACKAGE_AICCU) += aiccu
+package-$(BR2_PACKAGE_AMWALL) += amwall
 package-$(BR2_PACKAGE_ARPTABLES) += arptables
 package-$(BR2_PACKAGE_ARPWATCH) += arpwatch
 package-$(BR2_PACKAGE_ASTERISK) += asterisk
@@ -46,6 +47,7 @@ package-$(BR2_PACKAGE_KISMET) += kismet
 package-$(BR2_PACKAGE_L2TPD) += l2tpd
 package-$(BR2_PACKAGE_LCD4LINUX) += lcd4linux
 package-$(BR2_PACKAGE_LESS) += less
+package-$(BR2_PACKAGE_LIBAMSEL) += libamsel
 package-$(BR2_PACKAGE_LIBDB) += libdb
 package-$(BR2_PACKAGE_LIBELF) += libelf
 package-$(BR2_PACKAGE_LIBEVENT) += libevent
@@ -149,6 +151,7 @@ clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
 compile: $(patsubst %,%-compile,$(package-y) $(package-m))
 install: $(patsubst %,%-install,$(package-y))
 
+amwall-compile: libamsel-compile
 arpwatch-compile: libpcap-compile
 bind-compile: openssl-compile
 cyrus-sasl-compile: openssl-compile
diff --git a/openwrt/package/amwall/Config.in b/openwrt/package/amwall/Config.in
new file mode 100644
index 0000000000..978c63ee6e
--- /dev/null
+++ b/openwrt/package/amwall/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_AMWALL
+        tristate "amwall - pf to iptables "
+	default m if CONFIG_DEVEL
+	select BR2_PACKAGE_LIBAMSEL
+        help
+          See 
+
+          http://amselinux.de/
+
diff --git a/openwrt/package/amwall/Makefile b/openwrt/package/amwall/Makefile
new file mode 100644
index 0000000000..173a5d467b
--- /dev/null
+++ b/openwrt/package/amwall/Makefile
@@ -0,0 +1,44 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=amwall
+PKG_VERSION:=0.1.0
+PKG_RELEASE:=1
+PKG_MD5SUM:=a8b6438e7fd9ccadc9f68824ae62349c
+
+PKG_SOURCE_URL:=ftp://ftp.amselinux.net/source/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,AMWALL,amwall,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.prepared
+	rm -rf $(PKG_INSTALL_DIR)
+	mkdir -p $(PKG_INSTALL_DIR)
+	$(MAKE) -C $(PKG_BUILD_DIR) \
+		$(TARGET_CONFIGURE_OPTS) \
+		LDIR=$(PKG_BUILD_DIR) \
+		AMSEL_INCLUDE="$(STAGING_DIR)/usr/include" \
+		OPT_LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+		PREFIX="/usr" \
+		CONFIG="$(PKG_BUILD_DIR)/etc/amsel" \
+		DESTDIR=$(PKG_INSTALL_DIR) \
+		all install
+	touch $@
+
+$(IPKG_AMWALL):
+	install -d -m0755 $(IDIR_AMWALL)/usr/bin
+	cp -fpR $(PKG_INSTALL_DIR)/usr/bin/* $(IDIR_AMWALL)/usr/bin	
+	install -d -m0755 $(IDIR_AMWALL)/usr/sbin
+	cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/* $(IDIR_AMWALL)/usr/sbin	
+	install -d -m0755 $(IDIR_AMWALL)/etc/amsel
+	cp -fpR $(PKG_INSTALL_DIR)/etc/amsel* $(IDIR_AMWALL)/etc	
+	$(RSTRIP) $(IDIR_AMWALL)					
+	$(IPKG_BUILD) $(IDIR_AMWALL) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/amwall/ipkg/amwall.control b/openwrt/package/amwall/ipkg/amwall.control
new file mode 100644
index 0000000000..37678fb935
--- /dev/null
+++ b/openwrt/package/amwall/ipkg/amwall.control
@@ -0,0 +1,7 @@
+Package: amwall 
+Priority: optional
+Section: net
+Maintainer: Eymen Alyaz <dev@eymen.net>
+Source: http://amselinux.de
+Depends: libamsel
+Description: pf to iptables and more
diff --git a/openwrt/package/libamsel/Config.in b/openwrt/package/libamsel/Config.in
new file mode 100644
index 0000000000..fefaebb2ad
--- /dev/null
+++ b/openwrt/package/libamsel/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LIBAMSEL
+        tristate "libamsel - amwall library"
+        default m if CONFIG_DEVEL
+        help
+          A library for amwall configuration files
+
+          http://amselinux.de/
+
diff --git a/openwrt/package/libamsel/Makefile b/openwrt/package/libamsel/Makefile
new file mode 100644
index 0000000000..795787fdfb
--- /dev/null
+++ b/openwrt/package/libamsel/Makefile
@@ -0,0 +1,57 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libamsel
+PKG_VERSION:=20040621-cvs
+PKG_RELEASE:=1
+PKG_MD5SUM:=2077e620047404881a65d39c53c9917e
+
+PKG_SOURCE_URL:=ftp://ftp.amselinux.net/source/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,LIBAMSEL,libamsel,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.prepared
+	rm -rf $(PKG_INSTALL_DIR)
+	mkdir -p $(PKG_INSTALL_DIR)
+	$(MAKE) -C $(PKG_BUILD_DIR) \
+		$(TARGET_CONFIGURE_OPTS) \
+		LDIR=$(PKG_BUILD_DIR) \
+		PREFIX="$(PKG_INSTALL_DIR)/usr" \
+		all install
+	touch $@
+
+$(IPKG_LIBAMSEL):
+	install -d -m0755 $(IDIR_LIBAMSEL)/usr/lib
+	cp -fpR $(PKG_INSTALL_DIR)/usr/lib/* $(IDIR_LIBAMSEL)/usr/lib
+	$(RSTRIP) $(IDIR_LIBAMSEL)
+	$(IPKG_BUILD) $(IDIR_LIBAMSEL) $(PACKAGE_DIR)
+
+
+$(STAGING_DIR)/usr/lib/libamsel.so: $(PKG_BUILD_DIR)/.built
+	mkdir -p $(STAGING_DIR)/usr/include
+	cp -fpR $(PKG_INSTALL_DIR)/usr/include/amsel/compat.h $(STAGING_DIR)/usr/include/
+	mkdir -p $(STAGING_DIR)/usr/include/compat
+	cp -fpR $(PKG_INSTALL_DIR)/usr/include/amsel/compat/queue.h $(STAGING_DIR)/usr/include/compat
+	mkdir -p $(STAGING_DIR)/usr/lib/
+	cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libamsel.so $(STAGING_DIR)/usr/lib/
+	touch $(STAGING_DIR)/usr/lib/libamsel.so
+	
+install-dev: $(STAGING_DIR)/usr/lib/libamsel.so
+
+uninstall-dev:
+	rm -rf \
+		$(STAGING_DIR)/usr/include/compat.h \
+		$(STAGING_DIR)/usr/include/compat \
+		$(STAGING_DIR)/usr/lib/libamsel.so \
+
+compile: install-dev
+clean: uninstall-dev
+
diff --git a/openwrt/package/libamsel/ipkg/libamsel.control b/openwrt/package/libamsel/ipkg/libamsel.control
new file mode 100644
index 0000000000..4a7455e405
--- /dev/null
+++ b/openwrt/package/libamsel/ipkg/libamsel.control
@@ -0,0 +1,6 @@
+Package: libamsel
+Priority: optional
+Section: libs
+Maintainer: Eymen Alyaz <dev@eymen.net>
+Source: http://amselinux.de
+Description: library for amwall