From: Waldemar Brodkorb <mail@waldemar-brodkorb.de>
Date: Mon, 29 Aug 2005 10:47:33 +0000 (+0000)
Subject: make a image for netgear, loader need to be ELF
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=dd7c30306de45867a23dc21ea9505cf5f950b04e;p=openwrt%2Fstaging%2Fdedeckeh.git

make a image for netgear, loader need to be ELF

SVN-Revision: 1784
---

diff --git a/openwrt/target/linux/image/brcm/Makefile b/openwrt/target/linux/image/brcm/Makefile
index c0c83c52f0..09f2d1429c 100644
--- a/openwrt/target/linux/image/brcm/Makefile
+++ b/openwrt/target/linux/image/brcm/Makefile
@@ -27,6 +27,15 @@ endif
 $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx:
 	$(STAGING_DIR)/bin/trx -o $@ $(BUILD_DIR)/loader.gz $(KDIR)/vmlinux.lzma $(TRXALIGN) $(KDIR)/root.$(FS)
 
+ifeq ($(KERNEL),2.6)
+FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
+
+$(BIN_DIR)/openwrt-wgt634u-2.6-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+	dd if=$(BUILD_DIR)/loader-0.04/loader.o of=$@ bs=65536 conv=sync
+	cat $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx >> $@
+
+install: $(BIN_DIR)/openwrt-wgt634u-2.6-$(FSNAME).bin
+endif
 
 ifeq ($(KERNEL),2.4)
 FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))