From: Nicolas Thill <nico@openwrt.org>
Date: Sun, 20 Apr 2008 09:46:45 +0000 (+0000)
Subject: add a gpio feature for devices supporting the generic GPIO interface
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=ddc57879ec7e2310ff544d5f9cc4bc02d7f07d05;p=openwrt%2Fstaging%2Fdangole.git

add a gpio feature for devices supporting the generic GPIO interface

SVN-Revision: 10879
---

diff --git a/include/target.mk b/include/target.mk
index 4f10a3db2b..ce842da795 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -126,6 +126,9 @@ ifeq ($(DUMP),1)
     .SILENT: $(TMP_CONFIG)
     .PRECIOUS: $(TMP_CONFIG)
 
+    ifneq ($(CONFIG_GENERIC_GPIO),)
+      FEATURES += gpio
+    endif
     ifneq ($(CONFIG_PCI),)
       FEATURES += pci
     endif
diff --git a/scripts/metadata.pl b/scripts/metadata.pl
index 6d75345196..51dcc425ba 100755
--- a/scripts/metadata.pl
+++ b/scripts/metadata.pl
@@ -152,6 +152,7 @@ sub target_config_features(@) {
 	while ($_ = shift @_) {
 		/broken/ and $ret .= "\tdepends BROKEN\n";
 		/display/ and $ret .= "\tselect DISPLAY_SUPPORT\n";
+		/gpio/ and $ret .= "\tselect GPIO_SUPPORT\n";
 		/pci/ and $ret .= "\tselect PCI_SUPPORT\n";
 		/usb/ and $ret .= "\tselect USB_SUPPORT\n";
 		/pcmcia/ and $ret .= "\tselect PCMCIA_SUPPORT\n";
diff --git a/target/Config.in b/target/Config.in
index aabe9c3034..505fcc9621 100644
--- a/target/Config.in
+++ b/target/Config.in
@@ -11,6 +11,9 @@ config LINUX_2_6
 config DISPLAY_SUPPORT
 	bool
 
+config GPIO_SUPPORT
+	bool
+
 config PCI_SUPPORT
 	bool