From: Jo-Philipp Wich <jow@openwrt.org>
Date: Sat, 3 Oct 2015 09:49:24 +0000 (+0000)
Subject: toplevel.mk: drop LD_LIBRARY_PATH overrides
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=dea417017edc6717e2662ab97b0af3d0b724d360;p=openwrt%2Fstaging%2Fnbd.git

toplevel.mk: drop LD_LIBRARY_PATH overrides

Overriding LD_LIBRARY_PATH for host utilities frequently leads to problems
with host executables loading shared libraries from the staging_dir, leading
to crashes due to incompatible ABIs.

Since most host utilties either embed a proper rpath or are reworked to link
statically we do not need the workaround anymore.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>

SVN-Revision: 47103
---

diff --git a/include/toplevel.mk b/include/toplevel.mk
index 70f4691678..0e6c55ae08 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -22,8 +22,6 @@ endif
 HOSTCC ?= $(CC)
 export RELEASE
 export REVISION
-export LD_LIBRARY_PATH:=$(subst ::,:,$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(TOPDIR)/staging_dir/host/lib)
-export DYLD_LIBRARY_PATH:=$(subst ::,:,$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(TOPDIR)/staging_dir/host/lib)
 export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
 export MAKE_JOBSERVER=$(filter --jobserver%,$(MAKEFLAGS))