From: Jo-Philipp Wich <jow@openwrt.org>
Date: Sun, 1 Jul 2012 11:48:54 +0000 (+0000)
Subject: include/image.mk: /tmp should have mode 1777
X-Git-Tag: reboot~13482
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=deff2382d0319d08836827e211d667c62921f3c3;p=openwrt%2Fstaging%2Fblogic.git

include/image.mk: /tmp should have mode 1777

On the off chance that the root filesystem's /tmp is used directly as a
temporary directory instead of having a tmpfs mounted over it, it should have
the sticky bit set.

Signed-off-by: Mark Mentovai <mark@moxienet.com>

SVN-Revision: 32572
---

diff --git a/include/image.mk b/include/image.mk
index b0d6dfae610d..1977fc84c043 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -146,7 +146,7 @@ define Image/mkfs/prepare/default
 	- $(FIND) $(TARGET_DIR) -type f -perm +0100 -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
 	- $(FIND) $(TARGET_DIR) -type d -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
 	$(INSTALL_DIR) $(TARGET_DIR)/tmp
-	chmod 0777 $(TARGET_DIR)/tmp
+	chmod 1777 $(TARGET_DIR)/tmp
 endef
 
 define Image/mkfs/prepare