From: Rosen Penev <rosenp@gmail.com>
Date: Wed, 3 Apr 2024 19:17:21 +0000 (-0700)
Subject: tools: rework tools-core dependecies
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e09d3fd2904a35beaf5e27e81538cd8061b0ef36;p=openwrt%2Fstaging%2Fansuel.git

tools: rework tools-core dependecies

ZSTD and libdeflate do not depend on SED nor flock, so instead of the whole
for loop that will filter 2 out of 4 core packages just specify that patch
and tar depend on sed explicitly.

ZSTD now depends on libdeflate since libdeflate-gzip will then be used to
unpack ZSTD as well as most tool archives.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
Signed-off-by: Robert Marko <robimarko@gmail.com>
---

diff --git a/tools/Makefile b/tools/Makefile
index 445101c012..f60a458f98 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -164,8 +164,10 @@ tools-core += zstd
 $(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(patsubst %,$(curdir)/%/compile,$(tools-core))))
 tools-y += $(tools-core)
 
-# make core tools depend on sed and flock
-$(foreach tool, $(filter-out zstd,$(tools-core)), $(eval $(curdir)/$(tool)/compile += $(curdir)/sed/compile))
+# make some core tools depend on sed and flock
+$(curdir)/patch/compile += $(curdir)/sed/compile
+$(curdir)/tar/compile += $(curdir)/sed/compile
+$(curdir)/zstd/compile += $(curdir)/libdeflate/compile
 
 $(curdir)/sed/compile := $(curdir)/flock/compile $(curdir)/zstd/compile
 tools-y += flock sed