From: Christian Lamparter <chunkeey@gmail.com>
Date: Fri, 15 Jul 2022 23:56:53 +0000 (+0200)
Subject: nu801: fix DEPENDS on bcm53xx
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e0e644493019e5c8ce35f415a8fe5c0698eb36a0;p=openwrt%2Fstaging%2Fjogo.git

nu801: fix DEPENDS on bcm53xx

the tacked on @TARGET_bcm53xx causes warnings:
tmp/.config-package.in:14027:warning: ignoring unsupported character '@'
tmp/.config-package.in:26028:warning: ignoring unsupported character '@'

this was wrong.

Fixes: be1761fa1488 ("nu801: add MR26 to the table")
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
---

diff --git a/package/system/gpio-cdev/nu801/Makefile b/package/system/gpio-cdev/nu801/Makefile
index 73de6210f6..f91fbbc8ae 100644
--- a/package/system/gpio-cdev/nu801/Makefile
+++ b/package/system/gpio-cdev/nu801/Makefile
@@ -20,7 +20,7 @@ define Package/nu801
   SECTION:=utils
   CATEGORY:=Utilities
   SUBMENU:=Userspace GPIO Drivers
-  DEPENDS:=@TARGET_x86||@TARGET_bcm53xx
+  DEPENDS:=@(TARGET_x86||TARGET_bcm53xx)
   KCONFIG:=CONFIG_GPIO_CDEV=y
   TITLE:=NU801 LED Driver
 endef