From: Rosen Penev <rosenp@gmail.com>
Date: Thu, 29 Oct 2020 07:12:16 +0000 (-0700)
Subject: prereq-build: add python 3.9 support
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e224a9a98fac9e86e7cf77446c2d95777021a72e;p=openwrt%2Fstaging%2Fblogic.git

prereq-build: add python 3.9 support

Fixes unmet dependency issue.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---

diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 8181812599f2..e7314b253b58 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -149,6 +149,7 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
 $(eval $(call CleanupPython2))
 
 $(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
+	python3.9 -V 2>&1 | grep 'Python 3', \
 	python3.8 -V 2>&1 | grep 'Python 3', \
 	python3.7 -V 2>&1 | grep 'Python 3', \
 	python3.6 -V 2>&1 | grep 'Python 3', \
@@ -156,6 +157,7 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
 	python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
 
 $(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
+	python3.9 -V 2>&1 | grep 'Python 3', \
 	python3.8 -V 2>&1 | grep 'Python 3', \
 	python3.7 -V 2>&1 | grep 'Python 3', \
 	python3.6 -V 2>&1 | grep 'Python 3', \