From: Koen Vandeputte <koen.vandeputte@ncentric.com>
Date: Thu, 21 Nov 2019 13:09:35 +0000 (+0100)
Subject: kernel: bump 4.19 to 4.19.85
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e29500eb849a18fa988a6ce53e10ad8c188e35df;p=openwrt%2Fstaging%2Fxback.git

kernel: bump 4.19 to 4.19.85

Refreshed all patches.

Altered patches:
- 080-sata_support.patch

Remove upstreamed:
- 034-v4.20-MIPS-BCM47XX-Enable-USB-power-on-Netgear-WNDR3400v3.patch
- 001-4.21-01-BCM63XX-fix-switch-core-reset-on-BCM6368.patch
- 073-qcom-ipq4019-fix-cpu0-s-qcom-saw2-reg-value.patch

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
---

diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 0050a35ff5..e8be42afc4 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.9 = .202
 LINUX_VERSION-4.14 = .155
-LINUX_VERSION-4.19 = .84
+LINUX_VERSION-4.19 = .85
 
 LINUX_KERNEL_HASH-4.9.202 = 8108ec1cd10fc40821c84e9f087dba10b1767aad66596f4a36925faef55e4ebf
 LINUX_KERNEL_HASH-4.14.155 = 77d61979556b81c95b81452fa10e1fe9368cbe2f9f80a13e4669b0464722e481
-LINUX_KERNEL_HASH-4.19.84 = 868b4a92619cb00ab142a20a67f000525b9605820d1b66faa4a183133eac0660
+LINUX_KERNEL_HASH-4.19.85 = 7bf435970aeeafd46263f49730087a61c4858d8b8fc5a4002ceac971b45f4fb7
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/brcm2708/patches-4.19/950-0129-gpiolib-Don-t-prevent-IRQ-usage-of-output-GPIOs.patch b/target/linux/brcm2708/patches-4.19/950-0129-gpiolib-Don-t-prevent-IRQ-usage-of-output-GPIOs.patch
index 2f1d32754c..c28ce4081f 100644
--- a/target/linux/brcm2708/patches-4.19/950-0129-gpiolib-Don-t-prevent-IRQ-usage-of-output-GPIOs.patch
+++ b/target/linux/brcm2708/patches-4.19/950-0129-gpiolib-Don-t-prevent-IRQ-usage-of-output-GPIOs.patch
@@ -26,7 +26,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  /* Device and char device-related information */
  static DEFINE_IDA(gpio_ida);
  static dev_t gpio_devt;
-@@ -2634,7 +2636,7 @@ int gpiod_direction_output(struct gpio_d
+@@ -2654,7 +2656,7 @@ int gpiod_direction_output(struct gpio_d
  		value = !!value;
  
  	/* GPIOs used for IRQs shall not be set as output */
@@ -35,7 +35,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  		gpiod_err(desc,
  			  "%s: tried to set a GPIO tied to an IRQ as output\n",
  			  __func__);
-@@ -3333,7 +3335,7 @@ int gpiochip_lock_as_irq(struct gpio_chi
+@@ -3353,7 +3355,7 @@ int gpiochip_lock_as_irq(struct gpio_chi
  		}
  	}
  
diff --git a/target/linux/brcm2708/patches-4.19/950-0134-net-lan78xx-Disable-TCP-Segmentation-Offload-TSO.patch b/target/linux/brcm2708/patches-4.19/950-0134-net-lan78xx-Disable-TCP-Segmentation-Offload-TSO.patch
index 6a403d4861..b33c4f4374 100644
--- a/target/linux/brcm2708/patches-4.19/950-0134-net-lan78xx-Disable-TCP-Segmentation-Offload-TSO.patch
+++ b/target/linux/brcm2708/patches-4.19/950-0134-net-lan78xx-Disable-TCP-Segmentation-Offload-TSO.patch
@@ -37,7 +37,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
  	u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -3006,8 +3015,14 @@ static int lan78xx_bind(struct lan78xx_n
+@@ -3011,8 +3020,14 @@ static int lan78xx_bind(struct lan78xx_n
  	if (DEFAULT_RX_CSUM_ENABLE)
  		dev->net->features |= NETIF_F_RXCSUM;
  
diff --git a/target/linux/brcm2708/patches-4.19/950-0298-lan78xx-Debounce-link-events-to-minimize-poll-storm.patch b/target/linux/brcm2708/patches-4.19/950-0298-lan78xx-Debounce-link-events-to-minimize-poll-storm.patch
index d4e61c2186..bff441c5e0 100644
--- a/target/linux/brcm2708/patches-4.19/950-0298-lan78xx-Debounce-link-events-to-minimize-poll-storm.patch
+++ b/target/linux/brcm2708/patches-4.19/950-0298-lan78xx-Debounce-link-events-to-minimize-poll-storm.patch
@@ -28,7 +28,7 @@ See: https://github.com/raspberrypi/linux/issues/2447
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
  	u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -3819,7 +3824,12 @@ static int lan78xx_probe(struct usb_inte
+@@ -3824,7 +3829,12 @@ static int lan78xx_probe(struct usb_inte
  	dev->pipe_intr = usb_rcvintpipe(dev->udev,
  					dev->ep_intr->desc.bEndpointAddress &
  					USB_ENDPOINT_NUMBER_MASK);
diff --git a/target/linux/brcm2708/patches-4.19/950-0479-lan78xx-use-default-alignment-for-rx-buffers.patch b/target/linux/brcm2708/patches-4.19/950-0479-lan78xx-use-default-alignment-for-rx-buffers.patch
index 3bc2582dc4..d8cf36f1ea 100644
--- a/target/linux/brcm2708/patches-4.19/950-0479-lan78xx-use-default-alignment-for-rx-buffers.patch
+++ b/target/linux/brcm2708/patches-4.19/950-0479-lan78xx-use-default-alignment-for-rx-buffers.patch
@@ -12,7 +12,7 @@ in both dwc_otg and in ipv6 processing.
 
 --- a/drivers/net/usb/lan78xx.c
 +++ b/drivers/net/usb/lan78xx.c
-@@ -3253,7 +3253,7 @@ static int rx_submit(struct lan78xx_net
+@@ -3258,7 +3258,7 @@ static int rx_submit(struct lan78xx_net
  	size_t size = dev->rx_urb_size;
  	int ret = 0;
  
diff --git a/target/linux/brcm2708/patches-4.19/950-0542-net-genet-enable-link-energy-detect-powerdown-for-ex.patch b/target/linux/brcm2708/patches-4.19/950-0542-net-genet-enable-link-energy-detect-powerdown-for-ex.patch
index 8a1d2f143d..c29457500e 100644
--- a/target/linux/brcm2708/patches-4.19/950-0542-net-genet-enable-link-energy-detect-powerdown-for-ex.patch
+++ b/target/linux/brcm2708/patches-4.19/950-0542-net-genet-enable-link-energy-detect-powerdown-for-ex.patch
@@ -20,7 +20,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
 
 --- a/drivers/net/ethernet/broadcom/genet/bcmmii.c
 +++ b/drivers/net/ethernet/broadcom/genet/bcmmii.c
-@@ -286,6 +286,8 @@ int bcmgenet_mii_probe(struct net_device
+@@ -285,6 +285,8 @@ int bcmgenet_mii_probe(struct net_device
  	/* Communicate the integrated PHY revision */
  	if (priv->internal_phy)
  		phy_flags = priv->gphy_rev;
diff --git a/target/linux/brcm2708/patches-4.19/950-0802-regulator-gpio-Allow-nonexclusive-GPIO-access.patch b/target/linux/brcm2708/patches-4.19/950-0802-regulator-gpio-Allow-nonexclusive-GPIO-access.patch
index 2c41dc0127..6276642997 100644
--- a/target/linux/brcm2708/patches-4.19/950-0802-regulator-gpio-Allow-nonexclusive-GPIO-access.patch
+++ b/target/linux/brcm2708/patches-4.19/950-0802-regulator-gpio-Allow-nonexclusive-GPIO-access.patch
@@ -41,7 +41,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
 
 --- a/drivers/gpio/gpiolib.c
 +++ b/drivers/gpio/gpiolib.c
-@@ -3959,8 +3959,23 @@ struct gpio_desc *__must_check gpiod_get
+@@ -3979,8 +3979,23 @@ struct gpio_desc *__must_check gpiod_get
  	 * the device name as label
  	 */
  	status = gpiod_request(desc, con_id ? con_id : devname);
diff --git a/target/linux/brcm2708/patches-4.19/950-0803-gpio-Enable-nonexclusive-gpiods-from-DT-nodes.patch b/target/linux/brcm2708/patches-4.19/950-0803-gpio-Enable-nonexclusive-gpiods-from-DT-nodes.patch
index f7564a58c0..d8e87919cf 100644
--- a/target/linux/brcm2708/patches-4.19/950-0803-gpio-Enable-nonexclusive-gpiods-from-DT-nodes.patch
+++ b/target/linux/brcm2708/patches-4.19/950-0803-gpio-Enable-nonexclusive-gpiods-from-DT-nodes.patch
@@ -23,7 +23,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
 
 --- a/drivers/gpio/gpiolib.c
 +++ b/drivers/gpio/gpiolib.c
-@@ -4033,6 +4033,8 @@ struct gpio_desc *gpiod_get_from_of_node
+@@ -4053,6 +4053,8 @@ struct gpio_desc *gpiod_get_from_of_node
  	transitory = flags & OF_GPIO_TRANSITORY;
  
  	ret = gpiod_request(desc, label);
diff --git a/target/linux/brcm47xx/patches-4.19/030-v4.20-MIPS-BCM47XX-Enable-USB-power-on-Netgear-WNDR3400v3.patch b/target/linux/brcm47xx/patches-4.19/030-v4.20-MIPS-BCM47XX-Enable-USB-power-on-Netgear-WNDR3400v3.patch
deleted file mode 100644
index c824e28317..0000000000
--- a/target/linux/brcm47xx/patches-4.19/030-v4.20-MIPS-BCM47XX-Enable-USB-power-on-Netgear-WNDR3400v3.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From feef7918667b84f9d5653c501542dd8d84ae32af Mon Sep 17 00:00:00 2001
-From: Tuomas Tynkkynen <tuomas.tynkkynen@iki.fi>
-Date: Sun, 19 Aug 2018 22:20:23 +0300
-Subject: [PATCH] MIPS: BCM47XX: Enable USB power on Netgear WNDR3400v3
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Setting GPIO 21 high seems to be required to enable power to USB ports
-on the WNDR3400v3. As there is already similar code for WNR3500L,
-make the existing USB power GPIO code generic and use that.
-
-Signed-off-by: Tuomas Tynkkynen <tuomas.tynkkynen@iki.fi>
-Acked-by: Hauke Mehrtens <hauke@hauke-m.de>
-Signed-off-by: Paul Burton <paul.burton@mips.com>
-Patchwork: https://patchwork.linux-mips.org/patch/20259/
-Cc: Rafał Miłecki <zajec5@gmail.com>
-Cc: linux-mips@linux-mips.org
-Cc: linux-kernel@vger.kernel.org
----
- arch/mips/bcm47xx/workarounds.c | 8 +++++---
- 1 file changed, 5 insertions(+), 3 deletions(-)
-
---- a/arch/mips/bcm47xx/workarounds.c
-+++ b/arch/mips/bcm47xx/workarounds.c
-@@ -5,9 +5,8 @@
- #include <bcm47xx_board.h>
- #include <bcm47xx.h>
- 
--static void __init bcm47xx_workarounds_netgear_wnr3500l(void)
-+static void __init bcm47xx_workarounds_enable_usb_power(int usb_power)
- {
--	const int usb_power = 12;
- 	int err;
- 
- 	err = gpio_request_one(usb_power, GPIOF_OUT_INIT_HIGH, "usb_power");
-@@ -23,7 +22,10 @@ void __init bcm47xx_workarounds(void)
- 
- 	switch (board) {
- 	case BCM47XX_BOARD_NETGEAR_WNR3500L:
--		bcm47xx_workarounds_netgear_wnr3500l();
-+		bcm47xx_workarounds_enable_usb_power(12);
-+		break;
-+	case BCM47XX_BOARD_NETGEAR_WNDR3400_V3:
-+		bcm47xx_workarounds_enable_usb_power(21);
- 		break;
- 	default:
- 		/* No workaround(s) needed */
diff --git a/target/linux/brcm63xx/patches-4.19/001-4.21-01-BCM63XX-fix-switch-core-reset-on-BCM6368.patch b/target/linux/brcm63xx/patches-4.19/001-4.21-01-BCM63XX-fix-switch-core-reset-on-BCM6368.patch
deleted file mode 100644
index 3914865c89..0000000000
--- a/target/linux/brcm63xx/patches-4.19/001-4.21-01-BCM63XX-fix-switch-core-reset-on-BCM6368.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From f1af8bb8e0879a3c2d9679a7274c2774335e9876 Mon Sep 17 00:00:00 2001
-From: Jonas Gorski <jonas.gorski@gmail.com>
-Date: Wed, 14 Nov 2018 12:06:41 +0100
-Subject: [PATCH] MIPS: BCM63XX: fix switch core reset on BCM6368
-
-The Ethernet Switch core mask was set to 0, causing the switch core to
-be not reset on BCM6368 on boot. Provide the proper mask so the switch
-core gets reset to a known good state.
-
-Fixes: 799faa626c71 ("MIPS: BCM63XX: add core reset helper")
-Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
----
- arch/mips/bcm63xx/reset.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/arch/mips/bcm63xx/reset.c
-+++ b/arch/mips/bcm63xx/reset.c
-@@ -120,7 +120,7 @@
- #define BCM6368_RESET_DSL	0
- #define BCM6368_RESET_SAR	SOFTRESET_6368_SAR_MASK
- #define BCM6368_RESET_EPHY	SOFTRESET_6368_EPHY_MASK
--#define BCM6368_RESET_ENETSW	0
-+#define BCM6368_RESET_ENETSW	SOFTRESET_6368_ENETSW_MASK
- #define BCM6368_RESET_PCM	SOFTRESET_6368_PCM_MASK
- #define BCM6368_RESET_MPI	SOFTRESET_6368_MPI_MASK
- #define BCM6368_RESET_PCIE	0
diff --git a/target/linux/brcm63xx/patches-4.19/402_bcm63xx_enet_vlan_incoming_fixed.patch b/target/linux/brcm63xx/patches-4.19/402_bcm63xx_enet_vlan_incoming_fixed.patch
index 7ef200ed99..c3b5778e0a 100644
--- a/target/linux/brcm63xx/patches-4.19/402_bcm63xx_enet_vlan_incoming_fixed.patch
+++ b/target/linux/brcm63xx/patches-4.19/402_bcm63xx_enet_vlan_incoming_fixed.patch
@@ -1,6 +1,6 @@
 --- a/drivers/net/ethernet/broadcom/bcm63xx_enet.c
 +++ b/drivers/net/ethernet/broadcom/bcm63xx_enet.c
-@@ -1633,7 +1633,7 @@ static int bcm_enet_change_mtu(struct ne
+@@ -1634,7 +1634,7 @@ static int bcm_enet_change_mtu(struct ne
  		return -EBUSY;
  
  	/* add ethernet header + vlan tag size */
diff --git a/target/linux/brcm63xx/patches-4.19/404-NET-bcm63xx_enet-move-phy_-dis-connect-into-probe-re.patch b/target/linux/brcm63xx/patches-4.19/404-NET-bcm63xx_enet-move-phy_-dis-connect-into-probe-re.patch
index 2eb36f8216..e30bd5b107 100644
--- a/target/linux/brcm63xx/patches-4.19/404-NET-bcm63xx_enet-move-phy_-dis-connect-into-probe-re.patch
+++ b/target/linux/brcm63xx/patches-4.19/404-NET-bcm63xx_enet-move-phy_-dis-connect-into-probe-re.patch
@@ -15,7 +15,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
 
 --- a/drivers/net/ethernet/broadcom/bcm63xx_enet.c
 +++ b/drivers/net/ethernet/broadcom/bcm63xx_enet.c
-@@ -866,10 +866,8 @@ static int bcm_enet_open(struct net_devi
+@@ -867,10 +867,8 @@ static int bcm_enet_open(struct net_devi
  	struct bcm_enet_priv *priv;
  	struct sockaddr addr;
  	struct device *kdev;
@@ -26,7 +26,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  	void *p;
  	u32 val;
  
-@@ -877,40 +875,10 @@ static int bcm_enet_open(struct net_devi
+@@ -878,40 +876,10 @@ static int bcm_enet_open(struct net_devi
  	kdev = &priv->pdev->dev;
  
  	if (priv->has_phy) {
@@ -68,7 +68,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  	}
  
  	/* mask all interrupts and request them */
-@@ -920,7 +888,7 @@ static int bcm_enet_open(struct net_devi
+@@ -921,7 +889,7 @@ static int bcm_enet_open(struct net_devi
  
  	ret = request_irq(dev->irq, bcm_enet_isr_mac, 0, dev->name, dev);
  	if (ret)
@@ -77,7 +77,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  
  	ret = request_irq(priv->irq_rx, bcm_enet_isr_dma, 0,
  			  dev->name, dev);
-@@ -1082,8 +1050,8 @@ static int bcm_enet_open(struct net_devi
+@@ -1083,8 +1051,8 @@ static int bcm_enet_open(struct net_devi
  	enet_dmac_writel(priv, priv->dma_chan_int_mask,
  			 ENETDMAC_IRMASK, priv->tx_chan);
  
@@ -88,7 +88,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  	else
  		bcm_enet_adjust_link(dev);
  
-@@ -1124,10 +1092,6 @@ out_freeirq_rx:
+@@ -1125,10 +1093,6 @@ out_freeirq_rx:
  out_freeirq:
  	free_irq(dev->irq, dev);
  
@@ -99,7 +99,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  	return ret;
  }
  
-@@ -1232,10 +1196,6 @@ static int bcm_enet_stop(struct net_devi
+@@ -1233,10 +1197,6 @@ static int bcm_enet_stop(struct net_devi
  	free_irq(priv->irq_rx, dev);
  	free_irq(dev->irq, dev);
  
@@ -110,7 +110,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  	return 0;
  }
  
-@@ -1801,14 +1761,47 @@ static int bcm_enet_probe(struct platfor
+@@ -1802,14 +1762,47 @@ static int bcm_enet_probe(struct platfor
  
  	/* do minimal hardware init to be able to probe mii bus */
  	bcm_enet_hw_preinit(priv);
@@ -159,7 +159,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  		}
  
  		bus = priv->mii_bus;
-@@ -1832,6 +1825,35 @@ static int bcm_enet_probe(struct platfor
+@@ -1833,6 +1826,35 @@ static int bcm_enet_probe(struct platfor
  			dev_err(&pdev->dev, "unable to register mdio bus\n");
  			goto out_free_mdio;
  		}
@@ -195,7 +195,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  	} else {
  
  		/* run platform code to initialize PHY device */
-@@ -1839,45 +1861,16 @@ static int bcm_enet_probe(struct platfor
+@@ -1840,45 +1862,16 @@ static int bcm_enet_probe(struct platfor
  		    pd->mii_config(dev, 1, bcm_enet_mdio_read_mii,
  				   bcm_enet_mdio_write_mii)) {
  			dev_err(&pdev->dev, "unable to configure mdio bus\n");
@@ -245,7 +245,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  	if (priv->mii_bus)
  		mdiobus_unregister(priv->mii_bus);
  
-@@ -1885,6 +1878,9 @@ out_free_mdio:
+@@ -1886,6 +1879,9 @@ out_free_mdio:
  	if (priv->mii_bus)
  		mdiobus_free(priv->mii_bus);
  
@@ -255,7 +255,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  out_uninit_hw:
  	/* turn off mdc clock */
  	enet_writel(priv, 0, ENET_MIISC_REG);
-@@ -1915,6 +1911,7 @@ static int bcm_enet_remove(struct platfo
+@@ -1916,6 +1912,7 @@ static int bcm_enet_remove(struct platfo
  	enet_writel(priv, 0, ENET_MIISC_REG);
  
  	if (priv->has_phy) {
diff --git a/target/linux/brcm63xx/patches-4.19/408-bcm63xx_enet-enable-rgmii-clock-on-external-ports.patch b/target/linux/brcm63xx/patches-4.19/408-bcm63xx_enet-enable-rgmii-clock-on-external-ports.patch
index 772e40b2b5..86940ae14d 100644
--- a/target/linux/brcm63xx/patches-4.19/408-bcm63xx_enet-enable-rgmii-clock-on-external-ports.patch
+++ b/target/linux/brcm63xx/patches-4.19/408-bcm63xx_enet-enable-rgmii-clock-on-external-ports.patch
@@ -32,7 +32,7 @@ Subject: [PATCH 54/81] bcm63xx_enet: enable rgmii clock on external ports
  #define ENETSW_MDIOC_EXT_MASK		(1 << 16)
 --- a/drivers/net/ethernet/broadcom/bcm63xx_enet.c
 +++ b/drivers/net/ethernet/broadcom/bcm63xx_enet.c
-@@ -2184,6 +2184,18 @@ static int bcm_enetsw_open(struct net_de
+@@ -2185,6 +2185,18 @@ static int bcm_enetsw_open(struct net_de
  		priv->sw_port_link[i] = 0;
  	}
  
diff --git a/target/linux/brcm63xx/patches-4.19/423-bcm63xx_enet_add_b53_support.patch b/target/linux/brcm63xx/patches-4.19/423-bcm63xx_enet_add_b53_support.patch
index 641c477ee5..3f093cf65c 100644
--- a/target/linux/brcm63xx/patches-4.19/423-bcm63xx_enet_add_b53_support.patch
+++ b/target/linux/brcm63xx/patches-4.19/423-bcm63xx_enet_add_b53_support.patch
@@ -20,7 +20,7 @@
  
  #include <bcm63xx_dev_enet.h>
  #include "bcm63xx_enet.h"
-@@ -1931,7 +1932,8 @@ static int bcm_enet_remove(struct platfo
+@@ -1932,7 +1933,8 @@ static int bcm_enet_remove(struct platfo
  	return 0;
  }
  
@@ -30,7 +30,7 @@
  	.probe	= bcm_enet_probe,
  	.remove	= bcm_enet_remove,
  	.driver	= {
-@@ -1940,6 +1942,42 @@ struct platform_driver bcm63xx_enet_driv
+@@ -1941,6 +1943,42 @@ struct platform_driver bcm63xx_enet_driv
  	},
  };
  
@@ -73,7 +73,7 @@
  /*
   * switch mii access callbacks
   */
-@@ -2196,29 +2234,6 @@ static int bcm_enetsw_open(struct net_de
+@@ -2197,29 +2235,6 @@ static int bcm_enetsw_open(struct net_de
  		enetsw_writeb(priv, rgmii_ctrl, ENETSW_RGMII_CTRL_REG(i));
  	}
  
@@ -103,7 +103,7 @@
  	/* initialize flow control buffer allocation */
  	enet_dma_writel(priv, ENETDMA_BUFALLOC_FORCE_MASK | 0,
  			ENETDMA_BUFALLOC_REG(priv->rx_chan));
-@@ -2674,6 +2689,9 @@ static int bcm_enetsw_probe(struct platf
+@@ -2675,6 +2690,9 @@ static int bcm_enetsw_probe(struct platf
  	struct bcm63xx_enetsw_platform_data *pd;
  	struct resource *res_mem;
  	int ret, irq_rx, irq_tx;
@@ -113,7 +113,7 @@
  
  	if (!bcm_enet_shared_base[0])
  		return -EPROBE_DEFER;
-@@ -2754,6 +2772,43 @@ static int bcm_enetsw_probe(struct platf
+@@ -2755,6 +2773,43 @@ static int bcm_enetsw_probe(struct platf
  	priv->pdev = pdev;
  	priv->net_dev = dev;
  
@@ -157,7 +157,7 @@
  	return 0;
  
  out_disable_clk:
-@@ -2775,6 +2830,9 @@ static int bcm_enetsw_remove(struct plat
+@@ -2776,6 +2831,9 @@ static int bcm_enetsw_remove(struct plat
  	priv = netdev_priv(dev);
  	unregister_netdev(dev);
  
diff --git a/target/linux/brcm63xx/patches-4.19/424-bcm63xx_enet_no_request_mem_region.patch b/target/linux/brcm63xx/patches-4.19/424-bcm63xx_enet_no_request_mem_region.patch
index f2b18b76d6..e956deac1a 100644
--- a/target/linux/brcm63xx/patches-4.19/424-bcm63xx_enet_no_request_mem_region.patch
+++ b/target/linux/brcm63xx/patches-4.19/424-bcm63xx_enet_no_request_mem_region.patch
@@ -1,6 +1,6 @@
 --- a/drivers/net/ethernet/broadcom/bcm63xx_enet.c
 +++ b/drivers/net/ethernet/broadcom/bcm63xx_enet.c
-@@ -2733,9 +2733,9 @@ static int bcm_enetsw_probe(struct platf
+@@ -2734,9 +2734,9 @@ static int bcm_enetsw_probe(struct platf
  	if (ret)
  		goto out;
  
diff --git a/target/linux/brcm63xx/patches-4.19/804-bcm63xx_enet_63268_rgmii_ports.patch b/target/linux/brcm63xx/patches-4.19/804-bcm63xx_enet_63268_rgmii_ports.patch
index d9cf170dae..683221d76e 100644
--- a/target/linux/brcm63xx/patches-4.19/804-bcm63xx_enet_63268_rgmii_ports.patch
+++ b/target/linux/brcm63xx/patches-4.19/804-bcm63xx_enet_63268_rgmii_ports.patch
@@ -1,6 +1,6 @@
 --- a/drivers/net/ethernet/broadcom/bcm63xx_enet.c
 +++ b/drivers/net/ethernet/broadcom/bcm63xx_enet.c
-@@ -2231,6 +2231,10 @@ static int bcm_enetsw_open(struct net_de
+@@ -2232,6 +2232,10 @@ static int bcm_enetsw_open(struct net_de
  
  		rgmii_ctrl = enetsw_readb(priv, ENETSW_RGMII_CTRL_REG(i));
  		rgmii_ctrl |= ENETSW_RGMII_CTRL_GMII_CLK_EN;
diff --git a/target/linux/cns3xxx/patches-4.19/080-sata_support.patch b/target/linux/cns3xxx/patches-4.19/080-sata_support.patch
index 20871916fb..65a5275bec 100644
--- a/target/linux/cns3xxx/patches-4.19/080-sata_support.patch
+++ b/target/linux/cns3xxx/patches-4.19/080-sata_support.patch
@@ -1,6 +1,6 @@
 --- a/drivers/ata/ahci_platform.c
 +++ b/drivers/ata/ahci_platform.c
-@@ -37,12 +37,23 @@ static struct scsi_host_template ahci_pl
+@@ -44,11 +44,18 @@ static struct scsi_host_template ahci_pl
  	AHCI_SHT(DRV_NAME),
  };
  
@@ -15,12 +15,26 @@
  {
  	struct device *dev = &pdev->dev;
  	struct ahci_host_priv *hpriv;
-+	const struct ata_port_info *info = &ahci_port_info;
+-	const struct ata_port_info *port;
++	const struct ata_port_info *port = &ahci_port_info;
  	int rc;
  
-+	if (IS_ENABLED(CONFIG_ARCH_CNS3XXX))
-+		info = &cns3xxx_port_info;
-+
  	hpriv = ahci_platform_get_resources(pdev,
- 					    AHCI_PLATFORM_GET_RESETS);
- 	if (IS_ERR(hpriv))
+@@ -66,9 +73,14 @@ static int ahci_probe(struct platform_de
+ 	if (of_device_is_compatible(dev->of_node, "hisilicon,hisi-ahci"))
+ 		hpriv->flags |= AHCI_HFLAG_NO_FBS | AHCI_HFLAG_NO_NCQ;
+ 
+-	port = acpi_device_get_match_data(dev);
+-	if (!port)
+-		port = &ahci_port_info;
++	if (IS_ENABLED(CONFIG_ARCH_CNS3XXX)) {
++		port = &cns3xxx_port_info;
++	}
++	else {
++		port = acpi_device_get_match_data(dev);
++		if (!port)
++			port = &ahci_port_info;
++	}
+ 
+ 	rc = ahci_platform_init_host(pdev, hpriv, port,
+ 				     &ahci_platform_sht);
diff --git a/target/linux/generic/pending-4.19/640-netfilter-nf_flow_table-add-hardware-offload-support.patch b/target/linux/generic/pending-4.19/640-netfilter-nf_flow_table-add-hardware-offload-support.patch
index 78b7cc9f3e..dcd9b187c3 100644
--- a/target/linux/generic/pending-4.19/640-netfilter-nf_flow_table-add-hardware-offload-support.patch
+++ b/target/linux/generic/pending-4.19/640-netfilter-nf_flow_table-add-hardware-offload-support.patch
@@ -506,7 +506,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
 +MODULE_ALIAS("nf-flow-table-hw");
 --- a/net/netfilter/nf_tables_api.c
 +++ b/net/netfilter/nf_tables_api.c
-@@ -5471,6 +5471,13 @@ static int nf_tables_flowtable_parse_hoo
+@@ -5473,6 +5473,13 @@ static int nf_tables_flowtable_parse_hoo
  	if (err < 0)
  		return err;
  
@@ -520,7 +520,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  	ops = kcalloc(n, sizeof(struct nf_hook_ops), GFP_KERNEL);
  	if (!ops)
  		return -ENOMEM;
-@@ -5602,10 +5609,19 @@ static int nf_tables_newflowtable(struct
+@@ -5604,10 +5611,19 @@ static int nf_tables_newflowtable(struct
  	}
  
  	flowtable->data.type = type;
@@ -540,7 +540,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  	err = nf_tables_flowtable_parse_hook(&ctx, nla[NFTA_FLOWTABLE_HOOK],
  					     flowtable);
  	if (err < 0)
-@@ -5731,7 +5747,8 @@ static int nf_tables_fill_flowtable_info
+@@ -5733,7 +5749,8 @@ static int nf_tables_fill_flowtable_info
  	    nla_put_string(skb, NFTA_FLOWTABLE_NAME, flowtable->name) ||
  	    nla_put_be32(skb, NFTA_FLOWTABLE_USE, htonl(flowtable->use)) ||
  	    nla_put_be64(skb, NFTA_FLOWTABLE_HANDLE, cpu_to_be64(flowtable->handle),
diff --git a/target/linux/ipq40xx/patches-4.19/073-v4.20-ARM-dts-qcom-ipq4019-fix-cpu0-s-qcom-saw2-reg-value.patch b/target/linux/ipq40xx/patches-4.19/073-v4.20-ARM-dts-qcom-ipq4019-fix-cpu0-s-qcom-saw2-reg-value.patch
deleted file mode 100644
index cd1370ea5e..0000000000
--- a/target/linux/ipq40xx/patches-4.19/073-v4.20-ARM-dts-qcom-ipq4019-fix-cpu0-s-qcom-saw2-reg-value.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From bd73a3dd257fb838bd456a18eeee0ef0224b7a40 Mon Sep 17 00:00:00 2001
-From: Christian Lamparter <chunkeey@gmail.com>
-Date: Wed, 25 Jul 2018 10:37:47 +0200
-Subject: [PATCH] ARM: dts: qcom: ipq4019: fix cpu0's qcom,saw2 reg value
-
-while compiling an ipq4019 target, dtc will complain:
-regulator@b089000 unit address format error, expected "2089000"
-
-The saw0 regulator reg value seems to be
-copied and pasted from qcom-ipq8064.dtsi.
-
-This patch fixes the reg value to match that of the
-unit address which in turn silences the warning.
-(There is no driver for qcom,saw2 right now.
-So this went unnoticed)
-
-Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
-Signed-off-by: John Crispin <john@phrozen.org>
-Signed-off-by: Andy Gross <andy.gross@linaro.org>
----
- arch/arm/boot/dts/qcom-ipq4019.dtsi | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/arch/arm/boot/dts/qcom-ipq4019.dtsi
-+++ b/arch/arm/boot/dts/qcom-ipq4019.dtsi
-@@ -325,7 +325,7 @@
- 
-                 saw0: regulator@b089000 {
-                         compatible = "qcom,saw2";
--                        reg = <0x02089000 0x1000>, <0x0b009000 0x1000>;
-+			reg = <0x0b089000 0x1000>, <0x0b009000 0x1000>;
-                         regulator;
-                 };
- 
diff --git a/target/linux/mediatek/patches-4.19/0101-pci-mediatek-backport-fix-pcie.patch b/target/linux/mediatek/patches-4.19/0101-pci-mediatek-backport-fix-pcie.patch
index cdb53954cf..009eedb583 100644
--- a/target/linux/mediatek/patches-4.19/0101-pci-mediatek-backport-fix-pcie.patch
+++ b/target/linux/mediatek/patches-4.19/0101-pci-mediatek-backport-fix-pcie.patch
@@ -362,7 +362,7 @@
  
  	return err;
  }
-@@ -1125,34 +1126,6 @@ static int mtk_pcie_request_resources(st
+@@ -1127,34 +1128,6 @@ static int mtk_pcie_request_resources(st
  	return 0;
  }
  
@@ -397,7 +397,7 @@
  static int mtk_pcie_probe(struct platform_device *pdev)
  {
  	struct device *dev = &pdev->dev;
-@@ -1179,7 +1152,14 @@ static int mtk_pcie_probe(struct platfor
+@@ -1181,7 +1154,14 @@ static int mtk_pcie_probe(struct platfor
  	if (err)
  		goto put_resources;
  
@@ -413,7 +413,7 @@
  	if (err)
  		goto put_resources;
  
-@@ -1192,6 +1172,80 @@ put_resources:
+@@ -1194,6 +1174,80 @@ put_resources:
  	return err;
  }
  
@@ -494,7 +494,7 @@
  static const struct mtk_pcie_soc mtk_pcie_soc_v1 = {
  	.ops = &mtk_pcie_ops,
  	.startup = mtk_pcie_startup_port,
-@@ -1220,10 +1274,13 @@ static const struct of_device_id mtk_pci
+@@ -1222,10 +1276,13 @@ static const struct of_device_id mtk_pci
  
  static struct platform_driver mtk_pcie_driver = {
  	.probe = mtk_pcie_probe,