From: John Crispin <john@openwrt.org>
Date: Mon, 3 Nov 2014 08:00:39 +0000 (+0000)
Subject: kernel/modules/vxlan: add +kmod-iptunnel as dependency
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e2d82442b7261014bf352a57ee76bee2df0d14de;p=openwrt%2Fstaging%2Fansuel.git

kernel/modules/vxlan: add +kmod-iptunnel as dependency

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>

SVN-Revision: 43154
---

diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 376b588982..8671df1318 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -147,6 +147,7 @@ $(eval $(call KernelPackage,8021q))
 define KernelPackage/vxlan
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=Native VXLAN Kernel support
+  DEPENDS:=+kmod-iptunnel
   KCONFIG:=CONFIG_VXLAN
   FILES:=$(LINUX_DIR)/drivers/net/vxlan.ko
   AUTOLOAD:=$(call AutoLoad,13,vxlan)