From: Jo-Philipp Wich <jow@openwrt.org>
Date: Fri, 10 Aug 2012 19:27:08 +0000 (+0000)
Subject: firmware-utils: link statically
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e2e55d7acd5962a238da38df4399ee7cb7799978;p=openwrt%2Fstaging%2Fdedeckeh.git

firmware-utils: link statically

SVN-Revision: 33117
---

diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 05b588f3b5..640dd23ee5 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 define cc
-	$(HOSTCC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
+	$(HOSTCC) $(HOST_CFLAGS) -include endian.h -static -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
 endef
 
 define Host/Compile