From: Rosen Penev <rosenp@gmail.com>
Date: Sun, 25 Sep 2022 01:42:59 +0000 (-0700)
Subject: tools/zstd: build libraries as static
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e3989094b801da63b7b65b2460ea30dfeb324cd3;p=openwrt%2Fstaging%2Fjogo.git

tools/zstd: build libraries as static

Enables to get rid of rpath hack for all users.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---

diff --git a/tools/zstd/Makefile b/tools/zstd/Makefile
index 93f6745976..65381e7cb4 100644
--- a/tools/zstd/Makefile
+++ b/tools/zstd/Makefile
@@ -17,9 +17,9 @@ include $(INCLUDE_DIR)/meson.mk
 MESON_HOST_BUILD_DIR:=$(HOST_BUILD_DIR)/build/meson/openwrt-build
 
 HOSTCC:= $(HOSTCC_NOCACHE)
-HOST_LDFLAGS += -Wl,-rpath,$(STAGING_DIR_HOST)/lib
 
 MESON_HOST_ARGS += \
+	-Ddefault_library=static \
 	-Dlegacy_level=7 \
 	-Ddebug_level=0 \
 	-Dbacktrace=false \