From: Sungbo Eo <mans0n@gorani.run>
Date: Sat, 12 Feb 2022 08:01:31 +0000 (+0900)
Subject: build: image: use UTC for zip timestamp
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e42764cc5fa364e9fa553903c56191484738965e;p=openwrt%2Fstaging%2Fxback.git

build: image: use UTC for zip timestamp

Zip uses DOS timestamp for mtime which is stored in local time and hence
depends on the timezone of the build system. Force zip to use UTC timezone
to make image builds more reproducible.

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
---

diff --git a/include/image-commands.mk b/include/image-commands.mk
index 939f5ef2db..21f851d205 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -541,8 +541,7 @@ define Build/zip
 	rm -rf $@.tmp
 	mkdir $@.tmp
 	mv $@ $@.tmp/$(word 1,$(1))
-
-	$(STAGING_DIR_HOST)/bin/zip -j -X \
+	TZ=UTC $(STAGING_DIR_HOST)/bin/zip -j -X \
 		$(if $(SOURCE_DATE_EPOCH),--mtime="$(SOURCE_DATE_EPOCH)") \
 		$(wordlist 2,$(words $(1)),$(1)) \
 		$@ $@.tmp/$(if $(word 1,$(1)),$(word 1,$(1)),$$(basename $@))