From: Imre Kaloz <kaloz@openwrt.org>
Date: Sun, 12 Apr 2015 20:45:55 +0000 (+0000)
Subject: orion: upgrade to 3.18 (compile tested only)
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e55532b7af58979b92027d4194fe9e102c381ec7;p=openwrt%2Fstaging%2Fsvanheule.git

orion: upgrade to 3.18 (compile tested only)

Signed-off-by: Imre Kaloz <kaloz@openwrt.org>

SVN-Revision: 45405
---

diff --git a/target/linux/orion/Makefile b/target/linux/orion/Makefile
index c83412d81c..58e74b8e4a 100644
--- a/target/linux/orion/Makefile
+++ b/target/linux/orion/Makefile
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2013 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -13,7 +13,7 @@ FEATURES:=broken
 SUBTARGETS:=generic harddisk
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-KERNEL_PATCHVER:=3.10
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/orion/config-default b/target/linux/orion/config-default
index c413a9808b..759c39af2d 100644
--- a/target/linux/orion/config-default
+++ b/target/linux/orion/config-default
@@ -45,6 +45,11 @@ CONFIG_CRYPTO_HW=y
 CONFIG_CRYPTO_RNG2=y
 CONFIG_CRYPTO_WORKQUEUE=y
 CONFIG_DEBUG_LL_INCLUDE="mach/debug-macro.S"
+# CONFIG_DEBUG_UART_8250_FLOW_CONTROL is not set
+CONFIG_DEBUG_UART_8250_SHIFT=2
+# CONFIG_DEBUG_UART_8250_WORD is not set
+CONFIG_DEBUG_UART_PHYS=0xf1012000
+CONFIG_DEBUG_UART_VIRT=0xfe012000
 # CONFIG_DEBUG_USER is not set
 CONFIG_DNOTIFY=y
 CONFIG_FRAME_POINTER=y
@@ -113,6 +118,7 @@ CONFIG_KTIME_SCALAR=y
 CONFIG_LEDS_GPIO=y
 # CONFIG_MACH_BIGDISK is not set
 # CONFIG_MACH_D2NET is not set
+# CONFIG_MACH_D2NET_DT is not set
 # CONFIG_MACH_DB88F5281 is not set
 # CONFIG_MACH_DNS323 is not set
 # CONFIG_MACH_DT2 is not set
@@ -123,11 +129,13 @@ CONFIG_LEDS_GPIO=y
 # CONFIG_MACH_LINKSTATION_MINI is not set
 # CONFIG_MACH_LINKSTATION_PRO is not set
 # CONFIG_MACH_MSS2 is not set
+# CONFIG_MACH_MSS2_DT is not set
 # CONFIG_MACH_MV2120 is not set
 # CONFIG_MACH_NET2BIG is not set
 # CONFIG_MACH_RD88F5181L_FXO is not set
 # CONFIG_MACH_RD88F5181L_GE is not set
 # CONFIG_MACH_RD88F5182 is not set
+# CONFIG_MACH_RD88F5182_DT is not set
 # CONFIG_MACH_RD88F6183AP_GE is not set
 # CONFIG_MACH_TERASTATION_PRO2 is not set
 # CONFIG_MACH_TS209 is not set
@@ -142,6 +150,7 @@ CONFIG_MTD_PHYSMAP=y
 CONFIG_MV643XX_ETH=y
 CONFIG_MVEBU_MBUS=y
 CONFIG_MVMDIO=y
+# CONFIG_MVNETA is not set
 CONFIG_NEED_DMA_MAP_STATE=y
 CONFIG_NEED_KUSER_HELPERS=y
 CONFIG_NEED_PER_CPU_KM=y
diff --git a/target/linux/orion/image/generic.mk b/target/linux/orion/image/generic.mk
index 5cf232c0ad..905997d8cb 100644
--- a/target/linux/orion/image/generic.mk
+++ b/target/linux/orion/image/generic.mk
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2013 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,7 +14,7 @@
 
 
 ## Kernel mtd partition size in KiB
-KERNEL_MTD_SIZE:=1024
+KERNEL_MTD_SIZE:=1280
 
 # Netgear WNR854T: erase size is 128KiB = 0x00020000 = 131072
 ERASE_SIZE_128K:=128
diff --git a/target/linux/orion/patches/100-wrt350nv2_openwrt_partition_map.patch b/target/linux/orion/patches/100-wrt350nv2_openwrt_partition_map.patch
index 5e2dc25141..89c2c9420b 100644
--- a/target/linux/orion/patches/100-wrt350nv2_openwrt_partition_map.patch
+++ b/target/linux/orion/patches/100-wrt350nv2_openwrt_partition_map.patch
@@ -5,13 +5,13 @@
  		.name		= "kernel",
  		.offset		= 0x00000000,
 -		.size		= 0x00760000,
-+		.size		= 0x00100000,	// change to kernel mtd size here (1/3)
++		.size		= 0x00140000,	// change to kernel mtd size here (1/3)
  	}, {
  		.name		= "rootfs",
 -		.offset		= 0x001a0000,
 -		.size		= 0x005c0000,
-+		.offset		= 0x00100000,	// change to kernel mtd size here (2/3)
-+		.size		= 0x00650000,	// adopt to kernel mtd size here (3/3) = 0x00750000 - <kernel mtd size>
++		.offset		= 0x00140000,	// change to kernel mtd size here (2/3)
++		.size		= 0x00610000,	// adopt to kernel mtd size here (3/3) = 0x00750000 - <kernel mtd size>
  	}, {
  		.name		= "lang",
  		.offset		= 0x00760000,
diff --git a/target/linux/orion/patches/101-wnr854t_partition_map.patch b/target/linux/orion/patches/101-wnr854t_partition_map.patch
index 9757d45784..881cfb773e 100644
--- a/target/linux/orion/patches/101-wnr854t_partition_map.patch
+++ b/target/linux/orion/patches/101-wnr854t_partition_map.patch
@@ -1,6 +1,18 @@
 --- a/arch/arm/mach-orion5x/wnr854t-setup.c
 +++ b/arch/arm/mach-orion5x/wnr854t-setup.c
-@@ -66,6 +66,10 @@ static struct mtd_partition wnr854t_nor_
+@@ -57,15 +57,19 @@ static struct mtd_partition wnr854t_nor_
+ 	{
+ 		.name		= "kernel",
+ 		.offset		= 0x00000000,
+-		.size		= 0x00100000,
++		.size		= 0x00140000,
+ 	}, {
+ 		.name		= "rootfs",
+-		.offset		= 0x00100000,
+-		.size		= 0x00660000,
++		.offset		= 0x00140000,
++		.size		= 0x00620000,
+ 	}, {
  		.name		= "uboot",
  		.offset		= 0x00760000,
  		.size		= 0x00040000,
diff --git a/target/linux/orion/patches/200-dt2_board_support.patch b/target/linux/orion/patches/200-dt2_board_support.patch
index a6606d59c0..6d3f55988e 100644
--- a/target/linux/orion/patches/200-dt2_board_support.patch
+++ b/target/linux/orion/patches/200-dt2_board_support.patch
@@ -1,8 +1,8 @@
 --- a/arch/arm/mach-orion5x/Kconfig
 +++ b/arch/arm/mach-orion5x/Kconfig
-@@ -23,6 +23,13 @@ config MACH_RD88F5182
- 	  Say 'Y' here if you want your kernel to support the
- 	  Marvell Orion-NAS (88F5182) RD2
+@@ -36,6 +36,13 @@ config MACH_RD88F5182_DT
+ 	  Say 'Y' here if you want your kernel to support the Marvell
+ 	  Orion-NAS (88F5182) RD2, Flattened Device Tree.
  
 +config MACH_DT2
 +	bool "Freecom DataTank Gateway"
@@ -16,9 +16,9 @@
  	select I2C_BOARDINFO
 --- a/arch/arm/mach-orion5x/Makefile
 +++ b/arch/arm/mach-orion5x/Makefile
-@@ -17,6 +17,7 @@ obj-$(CONFIG_MACH_BIGDISK)	+= d2net-setu
+@@ -14,6 +14,7 @@ obj-$(CONFIG_MACH_TS78XX)	+= ts78xx-setu
+ obj-$(CONFIG_MACH_MV2120)	+= mv2120-setup.o
  obj-$(CONFIG_MACH_NET2BIG)	+= net2big-setup.o
- obj-$(CONFIG_MACH_MSS2)		+= mss2-setup.o
  obj-$(CONFIG_MACH_WNR854T)	+= wnr854t-setup.o
 +obj-$(CONFIG_MACH_DT2)		+= dt2-setup.o
  obj-$(CONFIG_MACH_RD88F5181L_GE)	+= rd88f5181l-ge-setup.o
diff --git a/target/linux/orion/patches/210-wn802t_support.patch b/target/linux/orion/patches/210-wn802t_support.patch
index bf1e868f80..479498e3b8 100644
--- a/target/linux/orion/patches/210-wn802t_support.patch
+++ b/target/linux/orion/patches/210-wn802t_support.patch
@@ -1,6 +1,6 @@
 --- a/arch/arm/mach-orion5x/Kconfig
 +++ b/arch/arm/mach-orion5x/Kconfig
-@@ -146,10 +146,13 @@ config MACH_MSS2
+@@ -144,10 +144,13 @@ config MACH_MSS2_DT
  	  Maxtor Shared Storage II platform.
  
  config MACH_WNR854T
@@ -47,8 +47,8 @@
 +
  	orion5x_uart0_init();
  
- 	mvebu_mbus_add_window("devbus-boot", WNR854T_NOR_BOOT_BASE,
-@@ -166,7 +180,7 @@ static struct hw_pci wnr854t_pci __initd
+ 	mvebu_mbus_add_window_by_id(ORION_MBUS_DEVBUS_BOOT_TARGET,
+@@ -168,7 +182,7 @@ static struct hw_pci wnr854t_pci __initd
  
  static int __init wnr854t_pci_init(void)
  {
@@ -57,7 +57,7 @@
  		pci_common_init(&wnr854t_pci);
  
  	return 0;
-@@ -177,6 +191,18 @@ MACHINE_START(WNR854T, "Netgear WNR854T"
+@@ -179,6 +193,18 @@ MACHINE_START(WNR854T, "Netgear WNR854T"
  	/* Maintainer: Imre Kaloz <kaloz@openwrt.org> */
  	.atag_offset	= 0x100,
  	.init_machine	= wnr854t_init,
diff --git a/target/linux/orion/patches/400-fix-section-mismatch-warnings.patch b/target/linux/orion/patches/400-fix-section-mismatch-warnings.patch
deleted file mode 100644
index f0685d3751..0000000000
--- a/target/linux/orion/patches/400-fix-section-mismatch-warnings.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/arm/mach-orion5x/common.c
-+++ b/arch/arm/mach-orion5x/common.c
-@@ -242,7 +242,7 @@ void orion5x_setup_wins(void)
- 
- int orion5x_tclk;
- 
--int __init orion5x_find_tclk(void)
-+static __init int orion5x_find_tclk(void)
- {
- 	u32 dev, rev;
-