From: Sander Vanheule <sander@svanheule.net>
Date: Wed, 1 Jan 2025 21:18:05 +0000 (+0100)
Subject: realtek: trim default package selection
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e63d289bbd2f394538ee08fb51ba9f2326b57275;p=openwrt%2Fstaging%2Fsvanheule.git

realtek: trim default package selection

Images for certain devices are staring to become too large, as some
device only have 6MB available in their vendor partition layout for the
initial install. This is especially pressing for bootloaders only
supporting gzip compression.

Drop some packages from DEFAULT_PACKAGES that aren't strictly required
for a factory install. The user can always install more packages later
using opkg/apk, or via a sysupgrade to a custom build.

firewall4 is kept to ensure the most recent firewall package is selected
in builds including LuCI.
ethtool is kept as a frequently used diagnostics tool.

Link: https://github.com/openwrt/openwrt/pull/17450
Signed-off-by: Sander Vanheule <sander@svanheule.net>
(cherry picked from commit c9ae39b2d156ff893d88a7d75b9044aac2fdd8d0)
---

diff --git a/target/linux/realtek/Makefile b/target/linux/realtek/Makefile
index 2614b148c4..6cdd32a9d8 100644
--- a/target/linux/realtek/Makefile
+++ b/target/linux/realtek/Makefile
@@ -20,13 +20,8 @@ include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
 	ethtool \
 	firewall4 \
-	ip-bridge \
-	ip-full \
 	kmod-gpio-button-hotplug \
-	kmod-nft-offload \
-	nftables \
 	odhcp6c \
-	tc-bpf \
 	uboot-envtools \