From: Felix Fietkau <nbd@openwrt.org>
Date: Sat, 14 Oct 2006 11:23:23 +0000 (+0000)
Subject: add prereq check for case-sensitive filesystem
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e735d75cb92932b41ccb3b3f9adba567317b1c27;p=openwrt%2Fstaging%2Fblocktrron.git

add prereq check for case-sensitive filesystem

SVN-Revision: 5073
---

diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 486f573f83..10bc68ae15 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -30,6 +30,16 @@ $(eval $(call Require,working-make, \
 	Please install GNU make v3.81 or later. (This version has bugs) \
 ))
 
+define Require/case-sensitive-fs
+	rm -f $(TMP_DIR)/test.*
+	touch $(TMP_DIR)/test.fs
+	[ \! -f $(TMP_DIR)/test.FS ]
+endef
+
+$(eval $(call Require,case-sensitive-fs, \
+	OpenWrt can only be built on a case-sensitive filesystem \
+))
+
 define Require/working-gcc
 	echo 'int main(int argc, char **argv) { return 0; }' | \
 		gcc -x c -o $(TMP_DIR)/a.out -