From: Daniel Golle <daniel@makrotopia.org>
Date: Tue, 12 Jul 2022 18:55:38 +0000 (+0100)
Subject: uboot-mediatek: mark MT7621 variants as @BROKEN
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e760f065c6fd17005c5458e54d6cc0fb8356b4df;p=openwrt%2Fstaging%2Fjogo.git

uboot-mediatek: mark MT7621 variants as @BROKEN

Building U-Boot for the MT7621 SoC requires binman, a Python-based
host tool to generate images. For now, binman cannot work inside the
OpenWrt build system because it requires swig, so mark the MT7621
boards as borken to fix the ramips/mt7621 build until someone with
knowledge about Python and swig fixes the underlaying issue.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
---

diff --git a/package/boot/uboot-mediatek/Makefile b/package/boot/uboot-mediatek/Makefile
index a994b8be4d..48e6fd5a33 100644
--- a/package/boot/uboot-mediatek/Makefile
+++ b/package/boot/uboot-mediatek/Makefile
@@ -51,6 +51,7 @@ define U-Boot/mt7621_rfb
   BUILD_TARGET:=ramips
   BUILD_SUBTARGET:=mt7621
   UBOOT_IMAGE:=u-boot-mt7621.bin
+  DEPENDS:=@BROKEN
 endef
 
 define U-Boot/mt7621_nand_rfb
@@ -60,6 +61,7 @@ define U-Boot/mt7621_nand_rfb
   BUILD_TARGET:=ramips
   BUILD_SUBTARGET:=mt7621
   UBOOT_IMAGE:=u-boot-mt7621.bin
+  DEPENDS:=@BROKEN
 endef
 
 define U-Boot/mt7622_rfb1