From: Linus Walleij <linus.walleij@linaro.org>
Date: Fri, 19 Jan 2024 20:45:15 +0000 (+0100)
Subject: uboot-bmips: Add U-Boot for the BMIPS target
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e78e870859ff83b2611295c945f2b51478a1de60;p=openwrt%2Fstaging%2Flinusw.git

uboot-bmips: Add U-Boot for the BMIPS target

This is needed to boot the BCM6238-based Inteno XG6846.
Currently this is restricted to the XG6846 board.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
---

diff --git a/.github/labeler.yml b/.github/labeler.yml
index fd26dd7f38..beb7787d34 100644
--- a/.github/labeler.yml
+++ b/.github/labeler.yml
@@ -30,6 +30,7 @@
   - "package/boot/arm-trusted-firmware-bcm63xx/**"
 "target/bmips":
   - "target/linux/bmips/**"
+  - "package/boot/uboot-bmips/**"
 "target/d1":
   - "target/linux/d1/**"
   - "package/boot/uboot-d1/**"
diff --git a/package/boot/uboot-bmips/Makefile b/package/boot/uboot-bmips/Makefile
new file mode 100644
index 0000000000..5581a6fbfc
--- /dev/null
+++ b/package/boot/uboot-bmips/Makefile
@@ -0,0 +1,32 @@
+include $(TOPDIR)/rules.mk
+
+PKG_VERSION:=2024.04
+PKG_HASH:=18a853fe39fad7ad03a90cc2d4275aeaed6da69735defac3492b80508843dd4a
+PKG_RELEASE:=$(AUTORELEASE)
+
+include $(INCLUDE_DIR)/u-boot.mk
+include $(INCLUDE_DIR)/package.mk
+
+define U-Boot/Default
+  BUILD_TARGET:=bmips
+  BUILD_SUBTARGET:=bcm6328
+  UBOOT_CONFIG:=inteno_xg6846_ram
+  UBOOT_BOARD:=$(1)
+endef
+
+define U-Boot/xg6846
+  NAME:=Inteno XG6846
+  BUILD_DEVICES:=inteno_xg6846
+endef
+
+UBOOT_TARGETS := xg6846
+
+define Build/InstallDev
+	$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+	$(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)-u-boot.bin
+endef
+
+define Package/u-boot/install/default
+endef
+
+$(eval $(call BuildPackage/U-Boot))