From: Felix Fietkau <nbd@openwrt.org>
Date: Sun, 27 Apr 2014 18:30:50 +0000 (+0000)
Subject: hostapd: fix eglibc 2.15 support
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e795250a1e2a77f3d0bfceeb56a5e07ed99b60ea;p=openwrt%2Fstaging%2Fstintel.git

hostapd: fix eglibc 2.15 support

This patch fixes compilation failure for hostapd when using eglibc 2.15.

Signed-off-by: Zachery Stoddard <zacherystoddard@gmail.com>

SVN-Revision: 40575
---

diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 2e8eae2069..80e00823fe 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -88,6 +88,7 @@ endif
 
 ifdef CONFIG_USE_EGLIBC
   TARGET_LDFLAGS += -lrt
+  TARGET_LDFLAGS_C += -lrt
 endif
 
 DRV_DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny @(!TARGET_avr32||BROKEN)
@@ -267,7 +268,7 @@ define Build/RunMake
 		$(TARGET_CONFIGURE_OPTS) \
 		$(DRIVER_MAKEOPTS) \
 		LIBS="$(TARGET_LDFLAGS)" \
-		LIBS_c="" \
+		LIBS_c="$(TARGET_LDFLAGS_C)" \
 		BCHECK= \
 		$(2)
 endef