From: Jo-Philipp Wich <jow@openwrt.org>
Date: Tue, 8 Dec 2009 20:52:58 +0000 (+0000)
Subject: iptables: add comment match to the core package
X-Git-Tag: reboot~21709
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e830181f478d4674d6372afed58b58fd578d172b;p=openwrt%2Fstaging%2Fxback.git

iptables: add comment match to the core package

SVN-Revision: 18706
---

diff --git a/include/netfilter.mk b/include/netfilter.mk
index b08d521f6f..9eeee4f6e1 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -65,7 +65,7 @@ $(eval $(call nf_add,EBTABLES_WATCHERS,CONFIG_BRIDGE_EBT_ULOG, $(P_EBT)ebt_ulog)
 $(eval $(call nf_add,EBTABLES_WATCHERS,CONFIG_BRIDGE_EBT_NFLOG, $(P_EBT)ebt_nflog))
 
 # userland only
-$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_CORE,CONFIG_IP_NF_IPTABLES, xt_standard ipt_icmp xt_tcp xt_udp)))
+$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_CORE,CONFIG_IP_NF_IPTABLES, xt_standard ipt_icmp xt_tcp xt_udp xt_comment)))
 
 $(eval $(call nf_add,IPT_CORE,CONFIG_IP_NF_MATCH_LIMIT, $(P_V4)ipt_limit))
 $(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_LIMIT, $(P_XT)xt_limit))
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index f4d59abd91..747cba3ecd 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -52,6 +52,7 @@ endef
 define Package/iptables/description
  IPv4 firewall administration tool.
  Includes support for:
+ - comment
  - limit
  - LOG
  - mac