From: Imre Kaloz <kaloz@openwrt.org>
Date: Tue, 4 Jan 2011 16:39:16 +0000 (+0000)
Subject: fix md5sum, use our mirror with a fixed-up filename to make sure we get the right... 
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e9013bff6617e3881be4177d20f127613fdecf59;p=openwrt%2Fstaging%2Fjow.git

fix md5sum, use our mirror with a fixed-up filename to make sure we get the right fw version

SVN-Revision: 24901
---

diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 5ce4a0116c..b1e12341e1 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -117,9 +117,9 @@ endef
 $(eval $(call Download,p54spi))
 
 define Download/carl9170
-  FILE:=$(CARL9170_FW)
-  URL:=http://www.kernel.org/pub/linux/kernel/people/chr/carl9170/fw/$(CARL9170_FW_VERSION)
-  MD5SUM:=114c43846ed1d2f89cc92bd0e2ec0589
+  FILE:=$(CARL9170_FW)-$(CARL9170_FW_VERSION)
+  URL:=http://downloads.openwrt.org/sources/
+  MD5SUM:=9e33ac39dcd610aa1ad80bbf4f1abccf
 endef
 $(eval $(call Download,carl9170))
 
@@ -453,7 +453,7 @@ endef
 
 define KernelPackage/carl9170/install
 	$(INSTALL_DIR) $(1)/lib/firmware
-	$(INSTALL_DATA) $(DL_DIR)/$(CARL9170_FW) $(1)/lib/firmware/
+	$(INSTALL_DATA) $(DL_DIR)/$(CARL9170_FW)-$(CARL9170_FW_VERSION) $(1)/lib/firmware/$(CARL9170_FW)
 endef