From: Gabor Juhos <juhosg@openwrt.org>
Date: Wed, 9 May 2012 10:48:36 +0000 (+0000)
Subject: package/kernel: add package for the ADT7473/7475/7476/7490 sensors
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=e976bf56006ea3709c60a8ada379e6efe0d6af9c;p=openwrt%2Fstaging%2Fdangole.git

package/kernel: add package for the ADT7473/7475/7476/7490 sensors

SVN-Revision: 31657
---

diff --git a/package/kernel/modules/hwmon.mk b/package/kernel/modules/hwmon.mk
index 94f21a67e4..d549336b3d 100644
--- a/package/kernel/modules/hwmon.mk
+++ b/package/kernel/modules/hwmon.mk
@@ -45,6 +45,21 @@ endef
 $(eval $(call KernelPackage,hwmon-vid))
 
 
+define KernelPackage/hwmon-adt7475
+  TITLE:=ADT7473/7475/7476/7490 monitoring support
+  KCONFIG:=CONFIG_SENSORS_ADT7475
+  FILES:=$(LINUX_DIR)/drivers/hwmon/adt7475.ko
+  AUTOLOAD:=$(call AutoLoad,60,adt7475)
+  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmon-vid)
+endef
+
+define KernelPackage/hwmon-adt7475/description
+  Kernel module for ADT7473/7475/7476/7490 thermal monitor chip.
+endef
+
+$(eval $(call KernelPackage,hwmon-adt7475))
+
+
 define KernelPackage/hwmon-lm63
   TITLE:=LM63/64 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM63