From: Kuang Rufan <master@a1983.com.cn>
Date: Thu, 27 Sep 2018 14:08:35 +0000 (+0800)
Subject: tools/sed: fix incorrect dependency.
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=eb31562370a3d7cd09598646a5ad50d3effcf1c0;p=openwrt%2Fstaging%2Fjow.git

tools/sed: fix incorrect dependency.

sed shall depend on xz instead of xz depends on sed.

Signed-off-by: Kuang Rufan <master@a1983.com.cn>
---

diff --git a/tools/Makefile b/tools/Makefile
index 294f6fe07f..cacba5bcb4 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -99,9 +99,10 @@ $(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(patsubst %,$(c
 tools-y += $(tools-core)
 
 # make core tools depend on sed and flock
-$(foreach tool, $(tools-core), $(eval $(curdir)/$(tool)/compile += $(curdir)/sed/compile))
+$(foreach tool, $(filter-out xz,$(tools-core)), $(eval $(curdir)/$(tool)/compile += $(curdir)/sed/compile))
+$(curdir)/xz/compile += $(curdir)/flock/compile
 
-$(curdir)/sed/compile := $(curdir)/flock/compile
+$(curdir)/sed/compile := $(curdir)/flock/compile $(curdir)/xz/compile
 tools-y += flock sed
 
 $(curdir)/autoremove := 1