From: Daniel Golle <daniel@makrotopia.org>
Date: Wed, 5 Jul 2017 14:25:23 +0000 (+0200)
Subject: bzip2: add symlink to binary
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=eb7c14d512482e18d05f61afa44205167ea094c0;p=openwrt%2Fstaging%2Fadrian.git

bzip2: add symlink to binary

Other distributions incl. the OpenWrt ImageBuilder and SDK
expect to find the bzip2 executable in /bin.
Create a symlink at that location for compatibility.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
---

diff --git a/package/utils/bzip2/Makefile b/package/utils/bzip2/Makefile
index c17dee136b..62c255a907 100644
--- a/package/utils/bzip2/Makefile
+++ b/package/utils/bzip2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bzip2
 PKG_VERSION:=1.0.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.bzip.org/$(PKG_VERSION)
@@ -82,6 +82,8 @@ endef
 define Package/bzip2/install
 	$(INSTALL_DIR) $(1)/usr/bin/
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/bzip2-shared $(1)/usr/bin/bzip2
+	$(INSTALL_DIR) $(1)/bin/
+	$(LN) ../usr/bin/bzip2 $(1)/bin/bzip2
 endef
 
 HOST_CFLAGS += \