From: John Crispin <john@openwrt.org>
Date: Tue, 25 Mar 2014 20:15:50 +0000 (+0000)
Subject: fs-tools: add back mount_root, jffs2reset and ffs2mark functionality
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=ec44a0f11e89101d31cd1bb7f9206fadede61e3e;p=openwrt%2Fstaging%2Fsvanheule.git

fs-tools: add back mount_root, jffs2reset and ffs2mark functionality

Signed-off-by: John Crispin <blogic@openwrt.org>

SVN-Revision: 40018
---

diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index 9a6aaeef1e..c16d6a5621 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fstools
-PKG_VERSION:=2014-02-27
+PKG_VERSION:=2014-03-25
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
@@ -39,6 +39,7 @@ endef
 define Package/fstools/install
 	$(INSTALL_DIR) $(1)/sbin
 
+	$(INSTALL_BIN) ./files/{jffs2reset,jffs2mark,mount_root} $(1)/sbin/
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/fs-state $(1)/sbin/
 	$(INSTALL_BIN) ./files/snapshot $(1)/sbin/
 endef
diff --git a/package/system/fstools/files/jffs2mark b/package/system/fstools/files/jffs2mark
new file mode 100644
index 0000000000..d0bc7ad007
--- /dev/null
+++ b/package/system/fstools/files/jffs2mark
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+fs-state overlay jffs2mark
diff --git a/package/system/fstools/files/jffs2reset b/package/system/fstools/files/jffs2reset
new file mode 100644
index 0000000000..cc3a8453db
--- /dev/null
+++ b/package/system/fstools/files/jffs2reset
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+fs-state overlay jffs2reset
diff --git a/package/system/fstools/files/mount_root b/package/system/fstools/files/mount_root
new file mode 100644
index 0000000000..860c194ce3
--- /dev/null
+++ b/package/system/fstools/files/mount_root
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+fs-state start