From: Mike Baker <mbm@openwrt.org>
Date: Mon, 20 Mar 2006 18:32:11 +0000 (+0000)
Subject: fix motion package aka - clean up someone elses's mess
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=ec65e39a75855a6b4f03ba1a8c02256582eb5db6;p=openwrt%2Fstaging%2Fthess.git

fix motion package aka - clean up someone elses's mess

SVN-Revision: 3419
---

diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index eaf9bf43c9..049a47a996 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -439,7 +439,7 @@ mini_httpd-compile: openssl-compile
 endif
 
 ifneq ($(BR2_PACKAGE_MOTION),)
-motion-compile: libjpeg-compile
+motion-compile: jpeg-compile
 endif
 
 ifneq ($(BR2_PACKAGE_MPD_MP3),)
diff --git a/openwrt/package/motion/Makefile b/openwrt/package/motion/Makefile
index 578d35be12..1cc30398e0 100644
--- a/openwrt/package/motion/Makefile
+++ b/openwrt/package/motion/Makefile
@@ -35,15 +35,15 @@ $(PKG_BUILD_DIR)/.built:
 	mkdir -p $(PKG_INSTALL_DIR)
 	$(MAKE) -C $(PKG_BUILD_DIR) \
 		$(TARGET_CONFIGURE_OPTS) \
-		install_prefix="$(PKG_INSTALL_DIR)" \
+		DESTDIR="$(PKG_INSTALL_DIR)" \
 		all install
 	touch $@
 
-$(IPKG_FOO):
-	install -d -m0755 $(IDIR_FOO)/usr/sbin
-	$(CP) $(PKG_INSTALL_DIR)/usr/sbin/motion $(IDIR_FOO)/usr/sbin
-	$(RSTRIP) $(IDIR_FOO)
-	$(IPKG_BUILD) $(IDIR_FOO) $(PACKAGE_DIR)
+$(IPKG_MOTION):
+	install -d -m0755 $(IDIR_MOTION)/usr/bin
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/motion $(IDIR_MOTION)/usr/bin
+	$(RSTRIP) $(IDIR_MOTION)
+	$(IPKG_BUILD) $(IDIR_MOTION) $(PACKAGE_DIR)
 
 mostlyclean:
 	make -C $(PKG_BUILD_DIR) clean