From: Gerry Rozema <groz@openwrt.org>
Date: Fri, 18 Aug 2006 12:39:49 +0000 (+0000)
Subject: Update for initramfs handling
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=eca439169141afa7609a346f99260e397485a981;p=openwrt%2Fstaging%2Fblocktrron.git

Update for initramfs handling

SVN-Revision: 4591
---

diff --git a/openwrt/include/kernel-build.mk b/openwrt/include/kernel-build.mk
index 5e4534281a..0ef00de35d 100644
--- a/openwrt/include/kernel-build.mk
+++ b/openwrt/include/kernel-build.mk
@@ -57,6 +57,7 @@ ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
 	echo 'CONFIG_INITRAMFS_ROOT_GID=0' >> $(LINUX_DIR)/.config
 	mkdir -p $(BUILD_DIR)/root/etc/init.d
 	$(CP) ../generic-2.6/files/init $(BUILD_DIR)/root/
+	$(CP) ../generic-2.6/files/postinit $(BUILD_DIR)/root/
 else
 	rm -f $(BUILD_DIR)/root/init $(BUILD_DIR)/root/etc/init.d/S00initramfs
 	echo 'CONFIG_INITRAMFS_SOURCE=""' >> $(LINUX_DIR)/.config