From: Rafał Dzięgiel <rafostar.github@gmail.com>
Date: Sat, 1 Aug 2020 21:09:20 +0000 (+0200)
Subject: mac80211: ath9k: enable OEM cards support on x86
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=ed2491ba673f2317465f58d6bf954aa30160e233;p=openwrt%2Fstaging%2Fjogo.git

mac80211: ath9k: enable OEM cards support on x86

A lot of devices running OpenWrt x86 arch (32 or 64 bit) are either
"home-made routers" or devices that use PC class OEM components.

This commit enables OEM cards support on those devices by default.

Signed-off-by: Rafał Dzięgiel <rafostar.github@gmail.com>
[reformat commit message]
Signed-off-by: David Bauer <mail@david-bauer.net>
---

diff --git a/package/kernel/mac80211/ath.mk b/package/kernel/mac80211/ath.mk
index 5db4be8daa..be3f4ed136 100644
--- a/package/kernel/mac80211/ath.mk
+++ b/package/kernel/mac80211/ath.mk
@@ -218,6 +218,7 @@ define KernelPackage/ath9k/config
 	config ATH9K_SUPPORT_PCOEM
 		bool "Support chips used in PC OEM cards"
 		depends on PACKAGE_kmod-ath9k
+		default y if (x86_64 || i386)
 
        config ATH9K_TX99
                bool "Enable TX99 support (WARNING: testing only, breaks normal operation!)"