From: Felix Fietkau <nbd@openwrt.org>
Date: Wed, 22 Oct 2014 08:57:07 +0000 (+0000)
Subject: build: optimize printing of disabled packages
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=edc8e2022a1d1e3a292cadfa1f64d8d5fb5780d9;p=openwrt%2Fstaging%2Fansuel.git

build: optimize printing of disabled packages

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 43015
---

diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index a4901b583f..ccba046d12 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -102,9 +102,7 @@ ifeq ($(DUMP),)
 			echo "$(1)" >> $(PKG_INSTALL_STAMP)
         endif
       else
-        compile: $(1)-disabled
-        $(1)-disabled:
-		@echo "WARNING: skipping $(1) -- package not selected" >&2
+        $$(info WARNING: skipping $(1) -- package not selected)
       endif
     endif
     endif