From: Felix Fietkau <nbd@openwrt.org>
Date: Sat, 14 Feb 2009 10:43:15 +0000 (+0000)
Subject: opkg: work around a gcc warning bug related to array bounds checking
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=f10075e5b6eb4877fb332536a62c260573c402bb;p=openwrt%2Fstaging%2Fdangole.git

opkg: work around a gcc warning bug related to array bounds checking

SVN-Revision: 14506
---

diff --git a/package/opkg/patches/005-array_warnings.patch b/package/opkg/patches/005-array_warnings.patch
new file mode 100644
index 0000000000..deaffbe33e
--- /dev/null
+++ b/package/opkg/patches/005-array_warnings.patch
@@ -0,0 +1,10 @@
+--- a/libopkg/Makefile.am
++++ b/libopkg/Makefile.am
+@@ -1,6 +1,6 @@
+ 
+ HOST_CPU=@host_cpu@
+-AM_CFLAGS=-Wall -Werror -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
++AM_CFLAGS=-Wall -Werror -Wno-array-bounds -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
+ 
+ libopkg_includedir=$(includedir)/libopkg
+ libopkg_include_HEADERS= opkg.h