From: Felix Fietkau <nbd@openwrt.org>
Date: Tue, 9 Oct 2012 15:38:55 +0000 (+0000)
Subject: ixp4xx: add missing reboot handlers (fixes #11577)
X-Git-Url: http://git.cdn.openwrt.org/?a=commitdiff_plain;h=f14b8d43f2a0320e40cff8a131cebbf01688b2bc;p=openwrt%2Fstaging%2Fblocktrron.git

ixp4xx: add missing reboot handlers (fixes #11577)

SVN-Revision: 33672
---

diff --git a/target/linux/ixp4xx/patches-3.3/105-wg302v1_support.patch b/target/linux/ixp4xx/patches-3.3/105-wg302v1_support.patch
index 1e8fdaa513..c9d5b9421a 100644
--- a/target/linux/ixp4xx/patches-3.3/105-wg302v1_support.patch
+++ b/target/linux/ixp4xx/patches-3.3/105-wg302v1_support.patch
@@ -112,7 +112,7 @@
 +subsys_initcall(wg302v1_pci_init);
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/wg302v1-setup.c
-@@ -0,0 +1,144 @@
+@@ -0,0 +1,145 @@
 +/*
 + * arch/arm/mach-ixp4xx/wg302v1-setup.c
 + *
@@ -255,5 +255,6 @@
 +#if defined(CONFIG_PCI)
 +	.dma_zone_size	= SZ_64M,
 +#endif
++	.restart	= ixp4xx_restart,
 +MACHINE_END
 +#endif
diff --git a/target/linux/ixp4xx/patches-3.3/110-pronghorn_series_support.patch b/target/linux/ixp4xx/patches-3.3/110-pronghorn_series_support.patch
index 529cddb436..f795fb576d 100644
--- a/target/linux/ixp4xx/patches-3.3/110-pronghorn_series_support.patch
+++ b/target/linux/ixp4xx/patches-3.3/110-pronghorn_series_support.patch
@@ -127,7 +127,7 @@
 +subsys_initcall(pronghorn_pci_init);
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/pronghorn-setup.c
-@@ -0,0 +1,247 @@
+@@ -0,0 +1,249 @@
 +/*
 + * arch/arm/mach-ixp4xx/pronghorn-setup.c
 + *
@@ -362,6 +362,7 @@
 +#if defined(CONFIG_PCI)
 +	.dma_zone_size	= SZ_64M,
 +#endif
++	.restart	= ixp4xx_restart,
 +MACHINE_END
 +
 +MACHINE_START(PRONGHORNMETRO, "ADI Engineering Pronghorn Metro")
@@ -374,6 +375,7 @@
 +#if defined(CONFIG_PCI)
 +	.dma_zone_size	= SZ_64M,
 +#endif
++	.restart	= ixp4xx_restart,
 +MACHINE_END
 --- a/arch/arm/mach-ixp4xx/include/mach/uncompress.h
 +++ b/arch/arm/mach-ixp4xx/include/mach/uncompress.h
diff --git a/target/linux/ixp4xx/patches-3.3/115-sidewinder_support.patch b/target/linux/ixp4xx/patches-3.3/115-sidewinder_support.patch
index f2e626d16a..0ffd839736 100644
--- a/target/linux/ixp4xx/patches-3.3/115-sidewinder_support.patch
+++ b/target/linux/ixp4xx/patches-3.3/115-sidewinder_support.patch
@@ -130,7 +130,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 +subsys_initcall(sidewinder_pci_init);
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/sidewinder-setup.c
-@@ -0,0 +1,150 @@
+@@ -0,0 +1,151 @@
 +/*
 + * arch/arm/mach-ixp4xx/sidewinder-setup.c
 + *
@@ -280,4 +280,5 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 +#if defined(CONFIG_PCI)
 +	.dma_zone_size	= SZ_64M,
 +#endif
++	.restart	= ixp4xx_restart,
 +MACHINE_END
diff --git a/target/linux/ixp4xx/patches-3.3/120-compex_support.patch b/target/linux/ixp4xx/patches-3.3/120-compex_support.patch
index da59f4c075..3166f67220 100644
--- a/target/linux/ixp4xx/patches-3.3/120-compex_support.patch
+++ b/target/linux/ixp4xx/patches-3.3/120-compex_support.patch
@@ -50,7 +50,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
  obj-$(CONFIG_IXP4XX_QMGR)	+= ixp4xx_qmgr.o
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/compex-setup.c
-@@ -0,0 +1,137 @@
+@@ -0,0 +1,138 @@
 +/*
 + * arch/arm/mach-ixp4xx/compex-setup.c
 + *
@@ -187,6 +187,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 +#if defined(CONFIG_PCI)
 +	.dma_zone_size	= SZ_64M,
 +#endif
++	.restart	= ixp4xx_restart,
 +MACHINE_END
 --- a/arch/arm/mach-ixp4xx/ixdp425-pci.c
 +++ b/arch/arm/mach-ixp4xx/ixdp425-pci.c
diff --git a/target/linux/ixp4xx/patches-3.3/130-wrt300nv2_support.patch b/target/linux/ixp4xx/patches-3.3/130-wrt300nv2_support.patch
index caa2b3887e..638af29031 100644
--- a/target/linux/ixp4xx/patches-3.3/130-wrt300nv2_support.patch
+++ b/target/linux/ixp4xx/patches-3.3/130-wrt300nv2_support.patch
@@ -103,7 +103,7 @@
 +subsys_initcall(wrt300nv2_pci_init);
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/wrt300nv2-setup.c
-@@ -0,0 +1,109 @@
+@@ -0,0 +1,110 @@
 +/*
 + * arch/arm/mach-ixp4xx/wrt300nv2-setup.c
 + *
@@ -211,6 +211,7 @@
 +#if defined(CONFIG_PCI)
 +	.dma_zone_size	= SZ_64M,
 +#endif
++	.restart	= ixp4xx_restart,
 +MACHINE_END
 +#endif
 --- a/arch/arm/mach-ixp4xx/include/mach/uncompress.h
diff --git a/target/linux/ixp4xx/patches-3.3/150-lanready_ap1000_support.patch b/target/linux/ixp4xx/patches-3.3/150-lanready_ap1000_support.patch
index da3c1432f3..c2b25b3cb7 100644
--- a/target/linux/ixp4xx/patches-3.3/150-lanready_ap1000_support.patch
+++ b/target/linux/ixp4xx/patches-3.3/150-lanready_ap1000_support.patch
@@ -1,6 +1,6 @@
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/ap1000-setup.c
-@@ -0,0 +1,152 @@
+@@ -0,0 +1,153 @@
 +/*
 + * arch/arm/mach-ixp4xx/ap1000-setup.c
 + *
@@ -151,6 +151,7 @@
 +#if defined(CONFIG_PCI)
 +	.dma_zone_size	= SZ_64M,
 +#endif
++	.restart	= ixp4xx_restart,
 +MACHINE_END
 +#endif
 --- a/arch/arm/mach-ixp4xx/ixdp425-pci.c
diff --git a/target/linux/ixp4xx/patches-3.3/160-delayed_uart_io.patch b/target/linux/ixp4xx/patches-3.3/160-delayed_uart_io.patch
index a3b1f25e5b..18d93979df 100644
--- a/target/linux/ixp4xx/patches-3.3/160-delayed_uart_io.patch
+++ b/target/linux/ixp4xx/patches-3.3/160-delayed_uart_io.patch
@@ -112,7 +112,7 @@ Add a new UART I/O type for slow busses such as the ixp4xx expansion bus
  	case UPIO_MEM:
  	case UPIO_MEM32:
  	case UPIO_AU:
-@@ -2435,6 +2436,7 @@ int uart_match_port(struct uart_port *po
+@@ -2436,6 +2437,7 @@ int uart_match_port(struct uart_port *po
  	case UPIO_HUB6:
  		return (port1->iobase == port2->iobase) &&
  		       (port1->hub6   == port2->hub6);
diff --git a/target/linux/ixp4xx/patches-3.3/180-tw5334_support.patch b/target/linux/ixp4xx/patches-3.3/180-tw5334_support.patch
index 2b6f0f0498..7d5a6f2203 100644
--- a/target/linux/ixp4xx/patches-3.3/180-tw5334_support.patch
+++ b/target/linux/ixp4xx/patches-3.3/180-tw5334_support.patch
@@ -35,7 +35,7 @@
  obj-$(CONFIG_IXP4XX_QMGR)	+= ixp4xx_qmgr.o
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/tw5334-setup.c
-@@ -0,0 +1,164 @@
+@@ -0,0 +1,165 @@
 +/*
 + * arch/arm/mach-ixp4xx/tw5334-setup.c
 + *
@@ -198,6 +198,7 @@
 +#if defined(CONFIG_PCI)
 +	.dma_zone_size	= SZ_64M,
 +#endif
++	.restart	= ixp4xx_restart,
 +MACHINE_END
 +#endif
 --- /dev/null
diff --git a/target/linux/ixp4xx/patches-3.3/185-mi424wr_support.patch b/target/linux/ixp4xx/patches-3.3/185-mi424wr_support.patch
index 08ad726407..4d61cee7a1 100644
--- a/target/linux/ixp4xx/patches-3.3/185-mi424wr_support.patch
+++ b/target/linux/ixp4xx/patches-3.3/185-mi424wr_support.patch
@@ -74,7 +74,7 @@
 +
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/mi424wr-setup.c
-@@ -0,0 +1,380 @@
+@@ -0,0 +1,381 @@
 +/*
 + * arch/arm/mach-ixp4xx/mi424wr-setup.c
 + *
@@ -453,6 +453,7 @@
 +#if defined(CONFIG_PCI)
 +	.dma_zone_size	= SZ_64M,
 +#endif
++	.restart	= ixp4xx_restart,
 +MACHINE_END
 +
 --- a/arch/arm/mach-ixp4xx/Makefile
diff --git a/target/linux/ixp4xx/patches-3.3/190-cambria_support.patch b/target/linux/ixp4xx/patches-3.3/190-cambria_support.patch
index 6cee21e89e..57dfdace8e 100644
--- a/target/linux/ixp4xx/patches-3.3/190-cambria_support.patch
+++ b/target/linux/ixp4xx/patches-3.3/190-cambria_support.patch
@@ -82,7 +82,7 @@
 +subsys_initcall(cambria_pci_init);
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/cambria-setup.c
-@@ -0,0 +1,1005 @@
+@@ -0,0 +1,1006 @@
 +/*
 + * arch/arm/mach-ixp4xx/cambria-setup.c
 + *
@@ -1087,6 +1087,7 @@
 +#if defined(CONFIG_PCI)
 +	.dma_zone_size	= SZ_64M,
 +#endif
++	.restart	= ixp4xx_restart,
 +MACHINE_END
 --- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
diff --git a/target/linux/ixp4xx/patches-3.3/500-usr8200_support.patch b/target/linux/ixp4xx/patches-3.3/500-usr8200_support.patch
index 8ce1b41293..38a6388971 100644
--- a/target/linux/ixp4xx/patches-3.3/500-usr8200_support.patch
+++ b/target/linux/ixp4xx/patches-3.3/500-usr8200_support.patch
@@ -116,7 +116,7 @@
 +subsys_initcall(usr8200_pci_init);
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/usr8200-setup.c
-@@ -0,0 +1,213 @@
+@@ -0,0 +1,214 @@
 +/*
 + * arch/arm/mach-ixp4xx/usr8200-setup.c
 + *
@@ -329,6 +329,7 @@
 +#if defined(CONFIG_PCI)
 +	.dma_zone_size	= SZ_64M,
 +#endif
++	.restart	= ixp4xx_restart,
 +MACHINE_END
 --- a/arch/arm/mach-ixp4xx/include/mach/uncompress.h
 +++ b/arch/arm/mach-ixp4xx/include/mach/uncompress.h
diff --git a/target/linux/ixp4xx/patches-3.3/520-tw2662_support.patch b/target/linux/ixp4xx/patches-3.3/520-tw2662_support.patch
index edce4771bf..c7940a7696 100644
--- a/target/linux/ixp4xx/patches-3.3/520-tw2662_support.patch
+++ b/target/linux/ixp4xx/patches-3.3/520-tw2662_support.patch
@@ -118,7 +118,7 @@
 +subsys_initcall(tw2662_pci_init);
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/tw2662-setup.c
-@@ -0,0 +1,212 @@
+@@ -0,0 +1,213 @@
 +/*
 + * arch/arm/mach-ixp4xx/tw2662-setup.c
 + *
@@ -329,5 +329,6 @@
 +#if defined(CONFIG_PCI)
 +	.dma_zone_size	= SZ_64M,
 +#endif
++	.restart	= ixp4xx_restart,
 +MACHINE_END
 +#endif